CVE-2019-3802 Additional information exposure with Spring Data JPA example matcher
Attackers can retrieve unintended data from Spring Data JPA queries by supplying maliciously crafted example values to specific string matchers.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2019-3802?
CVE-2019-3802 is a low-severity vulnerability in Spring Data JPA, published on 3 Jun 2019. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Official description
This affects Spring Data JPA in versions up to and including 2.1.6, 2.0.14 and 1.11.20. ExampleMatcher using ExampleMatcher.StringMatcher.STARTING, ExampleMatcher.StringMatcher.ENDING or ExampleMatcher.StringMatcher.CONTAINING could return more results than anticipated when a maliciously crafted example value is supplied.
Weakness: CWE-155
Which versions are affected by CVE-2019-3802?
6 open source packages ship an affected version, including org.springframework.data:spring-data-jpa. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
org.springframework.data:spring-data-jpa Maven | All versions | 1.11.22 |
org.springframework.data:spring-data-jpa Maven | All versions | 1.11.22 |
org.springframework.data:spring-data-jpa Maven | From 2.0.0 | 2.1.8 |
org.springframework.data:spring-data-jpa Maven | From 2.0.0 | 2.1.8 |
org.springframework.data:spring-data-jpa Maven | From 2.1.0 | 2.1.8 |
org.springframework.data:spring-data-jpa Maven | From 2.1.0 | 2.1.8 |
Products include Pivotal Software Spring Data Java Persistance Api.
How do I fix CVE-2019-3802?
Upgrade org.springframework.data:spring-data-jpa to a fixed version for your release line: 1.11.22 or 2.1.8.
Is CVE-2019-3802 being exploited?
There is no known exploitation of CVE-2019-3802 in the wild and no public exploit code.
Sources
Also known as GHSA-xggx-fx6w-v7ch.