CVE-2019-3808 Moodle XSS Vulnerability
Attackers with teacher or manager roles can execute arbitrary scripts due to missing XSS risk flags on group management capabilities.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2019-3808?
CVE-2019-3808 is a medium-severity cross-site scripting vulnerability in Moodle Moodle, published on 25 Mar 2019. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
A flaw was found in Moodle versions 3.6 to 3.6.1, 3.5 to 3.5.3, 3.4 to 3.4.6, 3.1 to 3.1.15 and earlier unsupported versions. The 'manage groups' capability did not have the 'XSS risk' flag assigned to it, but does have that access in certain places. Note that the capability is intended for use by trusted users, and is only assigned to teachers and managers by default.
Weakness: CWE-79
Which versions are affected by CVE-2019-3808?
8 open source packages ship an affected version, including moodle/moodle. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
moodle/moodle Packagist | All versions | 3.1.16 |
moodle/moodle Packagist | All versions | 3.1.16 |
moodle/moodle Packagist | From 3.2.0 | 3.4.7 |
moodle/moodle Packagist | From 3.2.0 | 3.4.7 |
moodle/moodle Packagist | From 3.5.0 | 3.5.4 |
moodle/moodle Packagist | From 3.5.0 | 3.5.4 |
2 more packages
moodle/moodle Packagist | From 3.6.0 | 3.6.2 |
moodle/moodle Packagist | From 3.6.0 | 3.6.2 |
Products include Moodle Moodle.
How do I fix CVE-2019-3808?
Upgrade moodle/moodle to a fixed version for your release line: 3.1.16, 3.4.7, 3.5.4 or 3.6.2.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2019-3808 being exploited?
There is no known exploitation of CVE-2019-3808 in the wild and no public exploit code.
Other vulnerabilities in Moodle Moodle
- CVE-2006-4935 File upload in n/a
- CVE-2006-4936 Moodle does not properly validate module instance id
- CVE-2004-2233 Unknown "front page vulnerability with Moodle servers" for Moodle before 1.3.2 has unknown impact and attack vectors.
- CVE-2004-2235 Cross-site scripting in n/a
- CVE-2004-2236 Other in n/a
Sources
Also known as GHSA-4r2p-wpv5-683w, UBUNTU-CVE-2019-3808.