CVE-2019-3809 Moodle Blind SSRF Risk in /badges/mybackpack.php
Attackers can exploit blind SSRF in Moodle's badge functionality to make unauthorized requests from the server, potentially accessing internal resources.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2019-3809?
CVE-2019-3809 is a medium-severity server-side request forgery vulnerability in Moodle Moodle, published on 25 Mar 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
A flaw was found in Moodle versions 3.1 to 3.1.15 and earlier unsupported versions. The mybackpack functionality allowed setting the URL of badges, when it should be restricted to the Mozilla Open Badges backpack URL. This resulted in the possibility of blind SSRF via requests made by the page.
Which versions are affected by CVE-2019-3809?
2 open source packages ship an affected version, including moodle/moodle. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
moodle/moodle Packagist | From 3.1 | 3.1.16 |
moodle/moodle Packagist | From 3.1 | 3.1.16 |
Products include Moodle Moodle.
How do I fix CVE-2019-3809?
Upgrade moodle/moodle to 3.1.16 or later.
Upgrade, and send outbound requests through an allow-list that blocks internal addresses. More about Server-side request forgery.
Is CVE-2019-3809 being exploited?
There is no known exploitation of CVE-2019-3809 in the wild and no public exploit code.
Other vulnerabilities in Moodle Moodle
- CVE-2006-4935 File upload in n/a
- CVE-2006-4936 Moodle does not properly validate module instance id
- CVE-2004-2233 Unknown "front page vulnerability with Moodle servers" for Moodle before 1.3.2 has unknown impact and attack vectors.
- CVE-2004-2235 Cross-site scripting in n/a
- CVE-2004-2236 Other in n/a
Sources
Also known as GHSA-jp4g-r8c9-3534, UBUNTU-CVE-2019-3809, USN-8805-1.