# CVE-2019-3809: Moodle Blind SSRF Risk in /badges/mybackpack.php

> Attackers can exploit blind SSRF in Moodle's badge functionality to make unauthorized requests from the server, potentially accessing internal resources.

- **Severity:** Medium 6.5 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 25 Mar 2019
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-jp4g-r8c9-3534, UBUNTU-CVE-2019-3809, USN-8805-1

## What is CVE-2019-3809?

CVE-2019-3809 is a medium-severity server-side request forgery vulnerability in Moodle Moodle, published on 25 Mar 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

A flaw was found in Moodle versions 3.1 to 3.1.15 and earlier unsupported versions. The mybackpack functionality allowed setting the URL of badges, when it should be restricted to the Mozilla Open Badges backpack URL. This resulted in the possibility of blind SSRF via requests made by the page.

Weakness: CWE-918 (Server-Side Request Forgery), CWE-352 (Cross-Site Request Forgery)

## Which versions are affected by CVE-2019-3809?

2 open source packages ship an affected version, including moodle/moodle. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `moodle/moodle` | Packagist | From 3.1 | 3.1.16 |
| `moodle/moodle` | Packagist | From 3.1 | 3.1.16 |

Products: Moodle Moodle.

## How do I fix CVE-2019-3809?

Upgrade moodle/moodle to 3.1.16 or later.

## Is CVE-2019-3809 being exploited?

There is no known exploitation of CVE-2019-3809 in the wild and no public exploit code.

## Other vulnerabilities in Moodle Moodle

- [CVE-2006-4935](https://insights.sbomify.com/CVE-2006-4935/): File upload in n/a (critical 10.0)
- [CVE-2006-4936](https://insights.sbomify.com/CVE-2006-4936/): Moodle does not properly validate module instance id (critical 10.0)
- [CVE-2004-2233](https://insights.sbomify.com/CVE-2004-2233/): Unknown "front page vulnerability with Moodle servers" for Moodle before 1.3.2 has unknown impact and attack vectors. (critical 10.0)
- [CVE-2004-2235](https://insights.sbomify.com/CVE-2004-2235/): Cross-site scripting in n/a (critical 10.0)
- [CVE-2004-2236](https://insights.sbomify.com/CVE-2004-2236/): Other in n/a (critical 10.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-3809 and fix it if it is affected.

What it is: CVE-2019-3809 is a medium-severity server-side request forgery vulnerability in Moodle Moodle, published on 25 Mar 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2019-3809 in the wild and no public exploit code.

Affected packages and fixed versions:
- moodle/moodle (Packagist): affected from 3.1; fixed in 3.1.16
- moodle/moodle (Packagist): affected from 3.1; fixed in 3.1.16

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-3809/ (Markdown: https://insights.sbomify.com/CVE-2019-3809/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-3809
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-3809
- OSV: https://osv.dev/vulnerability/CVE-2019-3809

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-3809/
Summaries are generated and may contain mistakes; the official description above is the record.
