CVE-2019-3810 Moodle XSS Vulnerability
Attackers can inject malicious scripts via unescaped user full names on the restricted userpix page, potentially leading to session hijacking or code execution.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2019-3810?
CVE-2019-3810 is a medium-severity cross-site scripting vulnerability in Moodle Moodle, published on 25 Mar 2019. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
A flaw was found in moodle versions 3.6 to 3.6.1, 3.5 to 3.5.3, 3.4 to 3.4.6, 3.1 to 3.1.15 and earlier unsupported versions. The /userpix/ page did not escape users' full names, which are included as text when hovering over profile images. Note this page is not linked to by default and its access is restricted.
Weakness: CWE-79
Which versions are affected by CVE-2019-3810?
8 open source packages ship an affected version, including moodle/moodle. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
moodle/moodle Packagist | From 3.1.0 | 3.1.15 |
moodle/moodle Packagist | From 3.1.0 | 3.1.15 |
moodle/moodle Packagist | From 3.4.0 | 3.4.6 |
moodle/moodle Packagist | From 3.4.0 | 3.4.6 |
moodle/moodle Packagist | From 3.5.0 | 3.5.3 |
moodle/moodle Packagist | From 3.5.0 | 3.5.3 |
2 more packages
moodle/moodle Packagist | From 3.6.0 | 3.6.1 |
moodle/moodle Packagist | From 3.6.0 | 3.6.1 |
Products include Moodle Moodle.
How do I fix CVE-2019-3810?
Upgrade moodle/moodle to a fixed version for your release line: 3.1.15, 3.4.6, 3.5.3 or 3.6.1.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2019-3810 being exploited?
There is no known exploitation of CVE-2019-3810 in the wild and no public exploit code.
Public exploit code: 1 Exploit-DB entry and 1 proofs of concept on GitHub.
Other vulnerabilities in Moodle Moodle
- CVE-2006-4935 File upload in n/a
- CVE-2006-4936 Moodle does not properly validate module instance id
- CVE-2004-2233 Unknown "front page vulnerability with Moodle servers" for Moodle before 1.3.2 has unknown impact and attack vectors.
- CVE-2004-2235 Cross-site scripting in n/a
- CVE-2004-2236 Other in n/a
Sources
Also known as GHSA-wm4w-8vc6-2j4h, UBUNTU-CVE-2019-3810.