# CVE-2019-3810: Moodle XSS Vulnerability

> Attackers can inject malicious scripts via unescaped user full names on the restricted userpix page, potentially leading to session hijacking or code execution.

- **Severity:** Medium 4.3 (`CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 25 Mar 2019
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-wm4w-8vc6-2j4h, UBUNTU-CVE-2019-3810

## What is CVE-2019-3810?

CVE-2019-3810 is a medium-severity cross-site scripting vulnerability in Moodle Moodle, published on 25 Mar 2019. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

A flaw was found in moodle versions 3.6 to 3.6.1, 3.5 to 3.5.3, 3.4 to 3.4.6, 3.1 to 3.1.15 and earlier unsupported versions. The /userpix/ page did not escape users' full names, which are included as text when hovering over profile images. Note this page is not linked to by default and its access is restricted.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2019-3810?

8 open source packages ship an affected version, including moodle/moodle. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `moodle/moodle` | Packagist | From 3.1.0 | 3.1.15 |
| `moodle/moodle` | Packagist | From 3.1.0 | 3.1.15 |
| `moodle/moodle` | Packagist | From 3.4.0 | 3.4.6 |
| `moodle/moodle` | Packagist | From 3.4.0 | 3.4.6 |
| `moodle/moodle` | Packagist | From 3.5.0 | 3.5.3 |
| `moodle/moodle` | Packagist | From 3.5.0 | 3.5.3 |
| `moodle/moodle` | Packagist | From 3.6.0 | 3.6.1 |
| `moodle/moodle` | Packagist | From 3.6.0 | 3.6.1 |

Products: Moodle Moodle.

## How do I fix CVE-2019-3810?

Upgrade moodle/moodle to a fixed version for your release line: 3.1.15, 3.4.6, 3.5.3 or 3.6.1.

## Is CVE-2019-3810 being exploited?

There is no known exploitation of CVE-2019-3810 in the wild and no public exploit code.

Public exploit code:

- Moodle (< 3.6.2, < 3.5.4, < 3.4.7, < 3.1.16) XSS PoC for Privilege Escalation (Student to Admin) (github_poc): https://github.com/farisv/Moodle-CVE-2019-3810
- Moodle 3.6.1 - Persistent Cross-Site Scripting (XSS) (exploitdb)

## Other vulnerabilities in Moodle Moodle

- [CVE-2006-4935](https://insights.sbomify.com/CVE-2006-4935/): File upload in n/a (critical 10.0)
- [CVE-2006-4936](https://insights.sbomify.com/CVE-2006-4936/): Moodle does not properly validate module instance id (critical 10.0)
- [CVE-2004-2233](https://insights.sbomify.com/CVE-2004-2233/): Unknown "front page vulnerability with Moodle servers" for Moodle before 1.3.2 has unknown impact and attack vectors. (critical 10.0)
- [CVE-2004-2235](https://insights.sbomify.com/CVE-2004-2235/): Cross-site scripting in n/a (critical 10.0)
- [CVE-2004-2236](https://insights.sbomify.com/CVE-2004-2236/): Other in n/a (critical 10.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-3810 and fix it if it is affected.

What it is: CVE-2019-3810 is a medium-severity cross-site scripting vulnerability in Moodle Moodle, published on 25 Mar 2019. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2019-3810 in the wild and no public exploit code.

Affected packages and fixed versions:
- moodle/moodle (Packagist): affected from 3.1.0; fixed in 3.1.15
- moodle/moodle (Packagist): affected from 3.1.0; fixed in 3.1.15
- moodle/moodle (Packagist): affected from 3.4.0; fixed in 3.4.6
- moodle/moodle (Packagist): affected from 3.4.0; fixed in 3.4.6
- moodle/moodle (Packagist): affected from 3.5.0; fixed in 3.5.3
- moodle/moodle (Packagist): affected from 3.5.0; fixed in 3.5.3
- moodle/moodle (Packagist): affected from 3.6.0; fixed in 3.6.1
- moodle/moodle (Packagist): affected from 3.6.0; fixed in 3.6.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-3810/ (Markdown: https://insights.sbomify.com/CVE-2019-3810/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-3810
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-3810
- OSV: https://osv.dev/vulnerability/CVE-2019-3810

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-3810/
Summaries are generated and may contain mistakes; the official description above is the record.
