# CVE-2019-3828: Ansible Path Traversal vulnerability

> Attackers can overwrite or read files outside the intended destination on the Ansible controller host via the fetch module.

- **Severity:** Medium 4.2 (`CVSS:3.0/AV:L/AC:L/PR:H/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 27 Mar 2019
- **Updated:** 4 Aug 2024
- **Also known as:** ALPINE-CVE-2019-3828, DEBIAN-CVE-2019-3828, GHSA-74vq-h4q8-x6jv, MGASA-2019-0114, OESA-2022-1565, PYSEC-2019-5, RHSA-2019:0430, RHSA-2019:0431, RHSA-2019:0432, RHSA-2019:0433, UBUNTU-CVE-2019-3828

## What is CVE-2019-3828?

CVE-2019-3828 is a medium-severity path traversal vulnerability in Red Hat Ansible, published on 27 Mar 2019. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

Ansible fetch module before versions 2.5.15, 2.6.14, 2.7.8 has a path traversal vulnerability which allows copying and overwriting files outside of the specified destination in the local ansible controller host, by not restricting an absolute path.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2019-3828?

7 open source packages ship an affected version, including ansible. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `ansible` | PyPI | All versions | 2.5.15 |
| `ansible` | PyPI | All versions | 2.5.15 |
| `ansible` | PyPI | From 2.5.0 | 2.5.15, 2.6.14, 2.7.8 |
| `ansible` | PyPI | From 2.6.0a1 | 2.6.14 |
| `ansible` | PyPI | From 2.6.0a1 | 2.6.14 |
| `ansible` | PyPI | From 2.7.0a1 | 2.7.8 |
| `ansible` | PyPI | From 2.7.0a1 | 2.7.8 |
| `ansible` | Red Hat:ansible_engine:2.5::el7 | All versions | 0:2.5.15-1.el7ae |
| `ansible-doc` | Red Hat:ansible_engine:2.5::el7 | All versions | 0:2.5.15-1.el7ae |
| `ansible` | Red Hat:ansible_engine:2.6::el7 | All versions | 0:2.6.14-1.el7ae |
| `ansible` | Red Hat:ansible_engine:2.7::el7 | All versions | 0:2.7.8-1.el7ae |
| `ansible` | Red Hat:ansible_engine:2::el7 | All versions | 0:2.7.8-1.el7ae |

Products: Redhat Ansible.

## How do I fix CVE-2019-3828?

Upgrade ansible to a fixed version for your release line: 2.5.15, 2.6.14 or 2.7.8.

## Is CVE-2019-3828 being exploited?

There is no known exploitation of CVE-2019-3828 in the wild and no public exploit code.

## Other vulnerabilities in Red Hat Ansible

- [CVE-2014-4657](https://insights.sbomify.com/CVE-2014-4657/): Ansible Remote Code Execution (critical 9.8)
- [CVE-2014-4966](https://insights.sbomify.com/CVE-2014-4966/): Ansible Arbitrary Code Execution (critical 9.8)
- [CVE-2014-4967](https://insights.sbomify.com/CVE-2014-4967/): Ansible Arbitrary Code Execution (critical 9.8)
- [CVE-2017-7550](https://insights.sbomify.com/CVE-2017-7550/): Ansible Insertion of Sensitive Information into Log File vulnerability (critical 9.8)
- [CVE-2014-3498](https://insights.sbomify.com/CVE-2014-3498/): Ansible Arbitrary Code Execution (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-3828 and fix it if it is affected.

What it is: CVE-2019-3828 is a medium-severity path traversal vulnerability in Red Hat Ansible, published on 27 Mar 2019. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2019-3828 in the wild and no public exploit code.

Affected packages and fixed versions:
- ansible (PyPI): affected all versions; fixed in 2.5.15
- ansible (PyPI): affected all versions; fixed in 2.5.15
- ansible (PyPI): affected from 2.5.0; fixed in 2.5.15, 2.6.14, 2.7.8
- ansible (PyPI): affected from 2.6.0a1; fixed in 2.6.14
- ansible (PyPI): affected from 2.6.0a1; fixed in 2.6.14
- ansible (PyPI): affected from 2.7.0a1; fixed in 2.7.8
- ansible (PyPI): affected from 2.7.0a1; fixed in 2.7.8

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-3828/ (Markdown: https://insights.sbomify.com/CVE-2019-3828/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-3828
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-3828
- OSV: https://osv.dev/vulnerability/CVE-2019-3828

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-3828/
Summaries are generated and may contain mistakes; the official description above is the record.
