CVE-2019-3847 Moodle XSS Vulnerability
Administrators viewing user dashboards can execute arbitrary JavaScript due to unescaped user content, potentially leading to session hijacking or code execution.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2019-3847?
CVE-2019-3847 is a medium-severity cross-site scripting vulnerability in Moodle Moodle, published on 27 Mar 2019. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
A vulnerability was found in moodle before versions 3.6.3, 3.5.5, 3.4.8 and 3.1.17. Users with the "login as other users" capability (such as administrators/managers) can access other users' Dashboards, but the JavaScript those other users may have added to their Dashboard was not being escaped when being viewed by the user logging in on their behalf.
Weakness: CWE-79
Which versions are affected by CVE-2019-3847?
8 open source packages ship an affected version, including moodle/moodle. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
moodle/moodle Packagist | All versions | 3.1.17 |
moodle/moodle Packagist | All versions | 3.1.17 |
moodle/moodle Packagist | From 3.2.0 | 3.4.8 |
moodle/moodle Packagist | From 3.2.0 | 3.4.8 |
moodle/moodle Packagist | From 3.5.0 | 3.5.5 |
moodle/moodle Packagist | From 3.5.0 | 3.5.5 |
2 more packages
moodle/moodle Packagist | From 3.6.0 | 3.6.3 |
moodle/moodle Packagist | From 3.6.0 | 3.6.3 |
Products include Moodle Moodle.
How do I fix CVE-2019-3847?
Upgrade moodle/moodle to a fixed version for your release line: 3.1.17, 3.4.8, 3.5.5 or 3.6.3.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2019-3847 being exploited?
There is no known exploitation of CVE-2019-3847 in the wild and no public exploit code.
Public exploit code: 1 proofs of concept on GitHub.
Other vulnerabilities in Moodle Moodle
- CVE-2006-4935 File upload in n/a
- CVE-2006-4936 Moodle does not properly validate module instance id
- CVE-2004-2233 Unknown "front page vulnerability with Moodle servers" for Moodle before 1.3.2 has unknown impact and attack vectors.
- CVE-2004-2235 Cross-site scripting in n/a
- CVE-2004-2236 Other in n/a
Sources
Also known as GHSA-qrcj-6fjw-3h9h, UBUNTU-CVE-2019-3847.