CVE-2019-3848 Moodle Logged in users could view all calendar events
Logged-in non-guest users can view unauthorized calendar events due to missing permission checks in the edit modal.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2019-3848?
CVE-2019-3848 is a medium-severity missing authorization vulnerability in Moodle Moodle, published on 26 Mar 2019. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
A vulnerability was found in moodle before versions 3.6.3, 3.5.5 and 3.4.8. Permissions were not correctly checked before loading event information into the calendar's edit event modal popup, so logged in non-guest users could view unauthorised calendar events. (Note: It was read-only access, users could not edit the events.)
Weakness: CWE-863
Which versions are affected by CVE-2019-3848?
6 open source packages ship an affected version, including moodle/moodle. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
moodle/moodle Packagist | From 3.4 | 3.4.8 |
moodle/moodle Packagist | From 3.4 | 3.4.8 |
moodle/moodle Packagist | From 3.5 | 3.5.5 |
moodle/moodle Packagist | From 3.5 | 3.5.5 |
moodle/moodle Packagist | From 3.6 | 3.6.3 |
moodle/moodle Packagist | From 3.6 | 3.6.3 |
Products include Moodle Moodle.
How do I fix CVE-2019-3848?
Upgrade moodle/moodle to a fixed version for your release line: 3.4.8, 3.5.5 or 3.6.3.
Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.
Is CVE-2019-3848 being exploited?
There is no known exploitation of CVE-2019-3848 in the wild and no public exploit code.
Other vulnerabilities in Moodle Moodle
- CVE-2006-4935 File upload in n/a
- CVE-2006-4936 Moodle does not properly validate module instance id
- CVE-2004-2233 Unknown "front page vulnerability with Moodle servers" for Moodle before 1.3.2 has unknown impact and attack vectors.
- CVE-2004-2235 Cross-site scripting in n/a
- CVE-2004-2236 Other in n/a
Sources
Also known as GHSA-45rw-4r25-jvg7.