CVE-2019-3850 Moodle Stored HTML in assignment submission comments allowed links to be opened directly
Attackers can exploit links in assignment comments to redirect users, potentially bypassing security controls or facilitating phishing attacks.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2019-3850?
CVE-2019-3850 is a medium-severity vulnerability in Moodle Moodle, published on 26 Mar 2019. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
A vulnerability was found in moodle before versions 3.6.3, 3.5.5, 3.4.8 and 3.1.17. Links within assignment submission comments would open directly (in the same window). Although links themselves may be valid, opening within the same window and without the no-referrer header policy made them more susceptible to exploits.
Weakness: CWE-601
Which versions are affected by CVE-2019-3850?
8 open source packages ship an affected version, including moodle/moodle. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
moodle/moodle Packagist | All versions | 3.1.17 |
moodle/moodle Packagist | All versions | 3.1.17 |
moodle/moodle Packagist | From 3.2.0 | 3.4.8 |
moodle/moodle Packagist | From 3.2.0 | 3.4.8 |
moodle/moodle Packagist | From 3.5.0 | 3.5.5 |
moodle/moodle Packagist | From 3.5.0 | 3.5.5 |
2 more packages
moodle/moodle Packagist | From 3.6.0 | 3.6.3 |
moodle/moodle Packagist | From 3.6.0 | 3.6.3 |
Products include Moodle Moodle.
How do I fix CVE-2019-3850?
Upgrade moodle/moodle to a fixed version for your release line: 3.1.17, 3.4.8, 3.5.5 or 3.6.3.
Is CVE-2019-3850 being exploited?
There is no known exploitation of CVE-2019-3850 in the wild and no public exploit code.
Other vulnerabilities in Moodle Moodle
- CVE-2006-4935 File upload in n/a
- CVE-2006-4936 Moodle does not properly validate module instance id
- CVE-2004-2233 Unknown "front page vulnerability with Moodle servers" for Moodle before 1.3.2 has unknown impact and attack vectors.
- CVE-2004-2235 Cross-site scripting in n/a
- CVE-2004-2236 Other in n/a
Sources
Also known as GHSA-3fj7-9j8m-7r8g, UBUNTU-CVE-2019-3850.