CVE-2019-3852 Moodle context freezing

Medium 4.3 Published Updated

Attackers can bypass capability checks in Moodle to access unauthorized user data or escalate privileges due to ignored context freezing.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2019-3852?

CVE-2019-3852 is a medium-severity missing authorization vulnerability in Moodle Moodle, published on 26 Mar 2019. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

A vulnerability was found in moodle before version 3.6.3. The get_with_capability_join and get_users_by_capability functions were not taking context freezing into account when checking user capabilities

Which versions are affected by CVE-2019-3852?

2 open source packages ship an affected version, including moodle/moodle. It affects 1 product.

PackageAffectedFixed in
moodle/moodle PackagistFrom 3.63.6.3
moodle/moodle PackagistFrom 3.63.6.3

Products include Moodle Moodle.

How do I fix CVE-2019-3852?

Upgrade moodle/moodle to 3.6.3 or later.

Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.

Is CVE-2019-3852 being exploited?

There is no known exploitation of CVE-2019-3852 in the wild and no public exploit code.

All Moodle Moodle vulnerabilities

Sources

Also known as GHSA-v2rh-5v88-rgvh, UBUNTU-CVE-2019-3852.

Is CVE-2019-3852 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free