{"answers":{"affected":"2 open source packages ship an affected version, including moodle/moodle. It affects 1 product.","exploited":"There is no known exploitation of CVE-2019-3852 in the wild and no public exploit code.","fix":"Upgrade moodle/moodle to 3.6.3 or later.","what":"CVE-2019-3852 is a medium-severity missing authorization vulnerability in Moodle Moodle, published on 26 Mar 2019. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2019-3852 and fix it if it is affected.\n\nWhat it is: CVE-2019-3852 is a medium-severity missing authorization vulnerability in Moodle Moodle, published on 26 Mar 2019. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2019-3852 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- moodle/moodle (Packagist): affected from 3.6; fixed in 3.6.3\n- moodle/moodle (Packagist): affected from 3.6; fixed in 3.6.3\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2019-3852/ (Markdown: https://insights.sbomify.com/CVE-2019-3852/index.md)","id":"CVE-2019-3852","markdown":"https://insights.sbomify.com/CVE-2019-3852/index.md","name":"CVE-2019-3852","record":{"aliases":["GHSA-v2rh-5v88-rgvh","UBUNTU-CVE-2019-3852"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["privilege_escalation","data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"Moodle LMS","requires_auth":"low_privilege","summary":"Attackers can bypass capability checks in Moodle to access unauthorized user data or escalate privileges due to ignored context freezing.","user_interaction":"not_required","vuln_class":"missing_authorization"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"redhat","cpe":[{"product":"moodle","vendor":"moodle"}],"cvss":{"score":4.3,"severity":"medium","source":"cna","vector":"CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N","version":"3.0"},"cwes":[],"description":"A vulnerability was found in moodle before version 3.6.3. The get_with_capability_join and get_users_by_capability functions were not taking context freezing into account when checking user capabilities","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Moodle context freezing","id":"CVE-2019-3852","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":"moodle:moodle","products":["moodle:moodle"],"type":"missing_authorization","year":"2019"},"n_packages":2,"n_references":2,"next":{"headline":"DO NOT USE THIS CANDIDATE NUMBER.","id":"CVE-2019-3853"},"packages":[{"ecosystem":"Packagist","fixed":["3.6.3"],"introduced":["3.6"],"last_affected":[],"package":"moodle/moodle","purl":null,"source":"GHSA-v2rh-5v88-rgvh"},{"ecosystem":"Packagist","fixed":["3.6.3"],"introduced":["3.6"],"last_affected":[],"package":"moodle/moodle","purl":"pkg:composer/moodle/moodle","source":"GHSA-v2rh-5v88-rgvh"}],"prev":{"headline":"Moodle Secure layout contained an insecure link in Boost theme","id":"CVE-2019-3851"},"products":["moodle"],"published":"2019-03-26","related":[{"cvss_score":10,"headline":"File upload in n/a","id":"CVE-2006-4935","kev_date_added":null,"published":"2006-09-23"},{"cvss_score":10,"headline":"Moodle does not properly validate module instance id","id":"CVE-2006-4936","kev_date_added":null,"published":"2006-09-23"},{"cvss_score":10,"headline":"Unknown \"front page vulnerability with Moodle servers\" for Moodle before 1.3.2 has unknown impact and attack vectors.","id":"CVE-2004-2233","kev_date_added":null,"published":"2005-07-17"},{"cvss_score":10,"headline":"Cross-site scripting in n/a","id":"CVE-2004-2235","kev_date_added":null,"published":"2005-07-17"},{"cvss_score":10,"headline":"Other in n/a","id":"CVE-2004-2236","kev_date_added":null,"published":"2005-07-17"},{"cvss_score":10,"headline":"Unknown vulnerability in Moodle before 1.3.4 has unknown impact and attack vectors, related to \"strings in Moodle texts.\"","id":"CVE-2004-2237","kev_date_added":null,"published":"2005-07-17"},{"cvss_score":10,"headline":"Multiple unknown vulnerabilities in Moodle before 1.5.1 have unknown impact and attack vectors.","id":"CVE-2005-2247","kev_date_added":null,"published":"2005-07-12"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-04","vendors":["[UNKNOWN]"]},"summary":"Attackers can bypass capability checks in Moodle to access unauthorized user data or escalate privileges due to ignored context freezing.","url":"https://insights.sbomify.com/CVE-2019-3852/"}