# CVE-2019-3881: Insecure path handling in Bundler

> An attacker can execute malicious code by placing files in a predictable temporary directory when the user's home directory is not writable.

- **Severity:** High 7.8 (`CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 4 Sep 2020
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-g98m-96g9-wfjq, OESA-2021-1419, SUSE-SU-2020:1582-1, SUSE-SU-2020:1582-2, UBUNTU-CVE-2019-3881, USN-4870-1, openSUSE-SU-2020:0803-1, openSUSE-SU-2020:0861-1

## What is CVE-2019-3881?

CVE-2019-3881 is a high-severity path traversal vulnerability in rubygem-bundler, published on 4 Sep 2020. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

Bundler prior to 2.1.0 uses a predictable path in /tmp/, created with insecure permissions as a storage location for gems, if locations under the user's home directory are not available. If Bundler is used in a scenario where the user does not have a writable home directory, an attacker could place malicious code in this directory that would be later loaded and executed.

Weakness: CWE-427 (Uncontrolled Search Path Element)

## Which versions are affected by CVE-2019-3881?

2 open source packages ship an affected version, including bundler. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `bundler` | RubyGems | From 1.14.0 | 2.1.0 |
| `bundler` | RubyGems | From 1.14.0 | 2.1.0 |
| `rubygem-bundler` | SUSE:Linux Enterprise Module for Basesystem 15 SP1 | All versions | 1.16.1-3.3.1 |
| `rubygem-bundler` | SUSE:Linux Enterprise Module for Basesystem 15 SP2 | All versions | 1.16.1-3.3.1 |
| `rubygem-bundler` | openSUSE:Leap 15.1 | All versions | 1.16.1-lp151.3.3.1 |
| `rubygem-bundler` | openSUSE:Leap 15.2 | All versions | 1.16.1-lp152.4.3.1 |

Products: Bundler Bundler.

## How do I fix CVE-2019-3881?

Upgrade bundler to 2.1.0 or later.

## Is CVE-2019-3881 being exploited?

There is no known exploitation of CVE-2019-3881 in the wild and no public exploit code.

## Other vulnerabilities in rubygem-bundler

- [CVE-2016-7954](https://insights.sbomify.com/CVE-2016-7954/): Bundler allows attacker to inject arbitrary code via secondary Gem source (critical 9.8)
- [CVE-2020-36327](https://insights.sbomify.com/CVE-2020-36327/): Dependency Confusion in Bundler (high 8.8)
- [CVE-2021-43809](https://insights.sbomify.com/CVE-2021-43809/): Local Code Execution through Argument Injection via dash leading git url parameter in Gemfile (medium 6.7)
- [CVE-2013-0334](https://insights.sbomify.com/CVE-2013-0334/): Bundler may install gems from a different source than expected (medium 5.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-3881 and fix it if it is affected.

What it is: CVE-2019-3881 is a high-severity path traversal vulnerability in rubygem-bundler, published on 4 Sep 2020. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2019-3881 in the wild and no public exploit code.

Affected packages and fixed versions:
- bundler (RubyGems): affected from 1.14.0; fixed in 2.1.0
- bundler (RubyGems): affected from 1.14.0; fixed in 2.1.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-3881/ (Markdown: https://insights.sbomify.com/CVE-2019-3881/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-3881
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-3881
- OSV: https://osv.dev/vulnerability/CVE-2019-3881

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-3881/
Summaries are generated and may contain mistakes; the official description above is the record.
