{"answers":{"affected":"It affects 3 products.","exploited":"There is no known exploitation of CVE-2019-3886 in the wild and no public exploit code.","fix":"Apply the vendor's patch.","what":"CVE-2019-3886 is a medium-severity missing authorization vulnerability in Fedoraproject Fedora, published on 4 Apr 2019. It can only be exploited from the same machine or local network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2019-3886 and fix it if it is affected.\n\nWhat it is: CVE-2019-3886 is a medium-severity missing authorization vulnerability in Fedoraproject Fedora, published on 4 Apr 2019. It can only be exploited from the same machine or local network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2019-3886 in the wild and no public exploit code.\n\nAffected product: Fedoraproject Fedora. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2019-3886/ (Markdown: https://insights.sbomify.com/CVE-2019-3886/index.md)","id":"CVE-2019-3886","markdown":"https://insights.sbomify.com/CVE-2019-3886/index.md","name":"CVE-2019-3886","record":{"aliases":["DEBIAN-CVE-2019-3886","GHSA-wxvx-hq9w-75x9","SUSE-SU-2019:1285-1"],"analysis":{"component_type":"server_software","fix_type":"patch","impacts":["data_read","denial_of_service"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"Virtualization management library","requires_auth":"none","summary":"Read-only users can invoke guest agent APIs in libvirt, potentially disclosing information or causing denial of service.","user_interaction":"not_required","vuln_class":"missing_authorization"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"redhat","cpe":[{"product":"fedora","vendor":"fedoraproject"},{"product":"leap","vendor":"opensuse"},{"product":"libvirt","vendor":"redhat"}],"cvss":{"score":5.4,"severity":"medium","source":"cna","vector":"CVSS:3.0/AV:A/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:L","version":"3.0"},"cwes":[{"id":"CWE-862","name":"Missing Authorization"}],"description":"An incorrect permissions check was discovered in libvirt 4.8.0 and above. The readonly permission was allowed to invoke APIs depending on the guest agent, which could lead to potentially disclosing unintended information or denial of service by causing libvirt to block.","ecosystems":["SUSE:Linux Enterprise Module for Basesystem 15","SUSE:Linux Enterprise Module for Server Applications 15"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Missing authorization in libvirt","id":"CVE-2019-3886","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":"fedoraproject:fedora","products":["fedoraproject:fedora","opensuse:leap","redhat:libvirt"],"type":"missing_authorization","year":"2019"},"n_packages":2,"n_references":7,"next":{"headline":"Denial of service in Kernel","id":"CVE-2019-3887"},"packages":[{"ecosystem":"SUSE:Linux Enterprise Module for Basesystem 15","fixed":["4.0.0-9.19.4"],"introduced":["0"],"last_affected":[],"package":"libvirt","purl":"pkg:rpm/suse/libvirt\u0026distro=SUSE%20Linux%20Enterprise%20Module%20for%20Basesystem%2015","source":"SUSE-SU-2019:1285-1"},{"ecosystem":"SUSE:Linux Enterprise Module for Server Applications 15","fixed":["4.0.0-9.19.4"],"introduced":["0"],"last_affected":[],"package":"libvirt","purl":"pkg:rpm/suse/libvirt\u0026distro=SUSE%20Linux%20Enterprise%20Module%20for%20Server%20Applications%2015","source":"SUSE-SU-2019:1285-1"}],"prev":{"headline":"Use after free in pacemaker","id":"CVE-2019-3885"},"products":["libvirt"],"published":"2019-04-04","related":[{"cvss_score":9.8,"headline":"PHP-CGI OS Command Injection","id":"CVE-2024-4577","kev_date_added":"2024-06-12","published":"2024-06-09"},{"cvss_score":9.8,"headline":"Grafana Authentication Bypass","id":"CVE-2021-39226","kev_date_added":"2022-08-25","published":"2021-10-05"},{"cvss_score":9.8,"headline":"VMware ESXi and Horizon DaaS OpenSLP Heap-Based Buffer Overflow","id":"CVE-2019-5544","kev_date_added":"2021-11-03","published":"2019-12-06"},{"cvss_score":9.6,"headline":"Google Chromium V8 Type Confusion","id":"CVE-2024-4947","kev_date_added":"2024-05-20","published":"2024-05-15"},{"cvss_score":9.6,"headline":"Google Chromium Visuals Use-After-Free","id":"CVE-2024-4671","kev_date_added":"2024-05-13","published":"2024-05-09"},{"cvss_score":9.6,"headline":"Google Chromium Mojo Insufficient Data Validation","id":"CVE-2022-3075","kev_date_added":"2022-09-08","published":"2022-09-26"},{"cvss_score":9.6,"headline":"Google Chromium Indexed DB API Use-After-Free","id":"CVE-2021-30633","kev_date_added":"2021-11-03","published":"2021-10-08"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"SUSE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-04","vendors":["The libvirt Project"]},"summary":"Read-only users can invoke guest agent APIs in libvirt, potentially disclosing information or causing denial of service.","url":"https://insights.sbomify.com/CVE-2019-3886/"}