# CVE-2019-3895: Openstack Octavia Access Control Vulnerability

> Attackers can upload arbitrary amphorae images in OpenStack Octavia deployments, leading to code execution when new instances are spawned.

- **Severity:** Medium 5.5 (`CVSS:3.0/AV:N/AC:L/PR:L/UI:R/S:U/C:L/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 3 Jun 2019
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-jjgh-m322-fjx6, PYSEC-2019-194, RHSA-2019:1683, RHSA-2019:1742, UBUNTU-CVE-2019-3895

## What is CVE-2019-3895?

CVE-2019-3895 is a medium-severity missing authorization vulnerability in Redhat Openstack, published on 3 Jun 2019. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

An access-control flaw was found in the Octavia service when the cloud platform was deployed using Red Hat OpenStack Platform Director. An attacker could cause new amphorae to run based on any arbitrary image. This meant that a remote attacker could upload a new amphorae image and, if requested to spawn new amphorae, Octavia would then pick up the compromised image.

Weakness: CWE-284 (Improper Access Control)

## Which versions are affected by CVE-2019-3895?

3 open source packages ship an affected version, including octavia. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `octavia` | PyPI | All versions | 0.9.0 |
| `octavia` | PyPI | All versions | 0.9.0 |
| `octavia` | PyPI | All versions | 0.9.0 |
| `openstack-tripleo-common` | Red Hat:openstack:13::el7 | All versions | 0:8.6.8-11.el7ost |
| `openstack-tripleo-common-container-base` | Red Hat:openstack:13::el7 | All versions | 0:8.6.8-11.el7ost |
| `openstack-tripleo-common-containers` | Red Hat:openstack:13::el7 | All versions | 0:8.6.8-11.el7ost |
| `openstack-tripleo-common-devtools` | Red Hat:openstack:13::el7 | All versions | 0:8.6.8-11.el7ost |
| `openstack-tripleo-common` | Red Hat:openstack:14::el7 | All versions | 0:9.5.0-5.el7ost |
| `openstack-tripleo-common-container-base` | Red Hat:openstack:14::el7 | All versions | 0:9.5.0-5.el7ost |
| `openstack-tripleo-common-containers` | Red Hat:openstack:14::el7 | All versions | 0:9.5.0-5.el7ost |
| `openstack-tripleo-common-devtools` | Red Hat:openstack:14::el7 | All versions | 0:9.5.0-5.el7ost |
| `python2-tripleo-common` | Red Hat:openstack:14::el7 | All versions | 0:9.5.0-5.el7ost |

Products: Openstack Octavia, Redhat Openstack.

## How do I fix CVE-2019-3895?

Upgrade octavia to 0.9.0 or later.

## Is CVE-2019-3895 being exploited?

There is no known exploitation of CVE-2019-3895 in the wild and no public exploit code.

## Other vulnerabilities in Redhat Openstack

- [CVE-2018-16856](https://insights.sbomify.com/CVE-2018-16856/): Openstack Octavia allows Insertion of Sensitive Information into Log File (medium 5.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-3895 and fix it if it is affected.

What it is: CVE-2019-3895 is a medium-severity missing authorization vulnerability in Redhat Openstack, published on 3 Jun 2019. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2019-3895 in the wild and no public exploit code.

Affected packages and fixed versions:
- octavia (PyPI): affected all versions; fixed in 0.9.0
- octavia (PyPI): affected all versions; fixed in 0.9.0
- octavia (PyPI): affected all versions; fixed in 0.9.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-3895/ (Markdown: https://insights.sbomify.com/CVE-2019-3895/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-3895
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-3895
- OSV: https://osv.dev/vulnerability/CVE-2019-3895

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-3895/
Summaries are generated and may contain mistakes; the official description above is the record.
