# CVE-2019-3902: Mercurial Path Traversal/Link Following vulnerability

> Attackers can use symlinks and subrepositories to bypass path checks and write files outside the repository directory.

- **Severity:** Medium 5.1 (`CVSS:3.0/AV:L/AC:H/PR:N/UI:N/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 22 Apr 2019
- **Updated:** 4 Aug 2024
- **Also known as:** ALPINE-CVE-2019-3902, DEBIAN-CVE-2019-3902, DLA-1764-1, GHSA-mq66-vcfc-8246, MGASA-2019-0250, PYSEC-2019-188, SUSE-SU-2020:1709-1, SUSE-SU-2020:1709-2, SUSE-SU-2020:3003-1, UBUNTU-CVE-2019-3902, openSUSE-SU-2020:0869-1, openSUSE-SU-2020:0880-1

## What is CVE-2019-3902?

CVE-2019-3902 is a medium-severity path traversal vulnerability in Debian Debian Linux, published on 22 Apr 2019. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

A flaw was found in Mercurial before 4.9. It was possible to use symlinks and subrepositories to defeat Mercurial's path-checking logic and write files outside a repository.

Weakness: CWE-59 (Improper Link Resolution Before File Access), CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2019-3902?

3 open source packages ship an affected version, including mercurial. It affects 3 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `mercurial` | PyPI | All versions | 4.9 |
| `mercurial` | PyPI | All versions | 4.9 |
| `mercurial` | PyPI | All versions | 4.9 |
| `mercurial` | SUSE:Linux Enterprise Module for Python 2 15 SP1 | All versions | 4.5.2-3.9.44 |
| `mercurial` | SUSE:Linux Enterprise Module for Python 2 15 SP2 | All versions | 4.5.2-3.9.44 |
| `mercurial` | SUSE:Linux Enterprise Software Development Kit 12 SP5 | All versions | 2.8.2-15.18.4 |
| `mercurial` | openSUSE:Leap 15.1 | All versions | 4.5.2-lp151.6.3.1 |
| `mercurial` | openSUSE:Leap 15.2 | All versions | 4.5.2-lp152.7.3.1 |

Products: Debian Debian Linux, Mercurial Mercurial, Redhat Enterprise Linux.

## How do I fix CVE-2019-3902?

Upgrade mercurial to 4.9 or later.

## Is CVE-2019-3902 being exploited?

There is no known exploitation of CVE-2019-3902 in the wild and no public exploit code.

## Other vulnerabilities in Debian Debian Linux

- [CVE-2015-3306](https://insights.sbomify.com/CVE-2015-3306/): ProFTPD Improper Access Control (critical 10.0, exploited in the wild)
- [CVE-2025-49113](https://insights.sbomify.com/CVE-2025-49113/): RoundCube Webmail Deserialization of Untrusted Data (critical 9.9, exploited in the wild)
- [CVE-2026-24061](https://insights.sbomify.com/CVE-2026-24061/): GNU InetUtils Argument Injection (critical 9.8, exploited in the wild)
- [CVE-2025-39682](https://insights.sbomify.com/CVE-2025-39682/): Linux Kernel Improper Check for Unusual or Exceptional Conditions (critical 9.8, exploited in the wild)
- [CVE-2024-9680](https://insights.sbomify.com/CVE-2024-9680/): Mozilla Firefox Use-After-Free (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-3902 and fix it if it is affected.

What it is: CVE-2019-3902 is a medium-severity path traversal vulnerability in Debian Debian Linux, published on 22 Apr 2019. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2019-3902 in the wild and no public exploit code.

Affected packages and fixed versions:
- mercurial (PyPI): affected all versions; fixed in 4.9
- mercurial (PyPI): affected all versions; fixed in 4.9
- mercurial (PyPI): affected all versions; fixed in 4.9

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-3902/ (Markdown: https://insights.sbomify.com/CVE-2019-3902/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-3902
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-3902
- OSV: https://osv.dev/vulnerability/CVE-2019-3902

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-3902/
Summaries are generated and may contain mistakes; the official description above is the record.
