{"answers":{"affected":"It affects 1 product.","exploited":"There is no known exploitation of CVE-2019-5401 in the wild and no public exploit code.","fix":"No fix has been published for CVE-2019-5401 yet. Limit exposure of the affected software until one is available.","what":"CVE-2019-5401 is a medium-severity cross-site scripting vulnerability in HP 2910-48G al Switch, published on 1 Aug 2019. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2019-5401 and fix it if it is affected.\n\nWhat it is: CVE-2019-5401 is a medium-severity cross-site scripting vulnerability in HP 2910-48G al Switch, published on 1 Aug 2019. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2019-5401 in the wild and no public exploit code.\n\nAffected product: HP 2910-48G al Switch. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2019-5401/ (Markdown: https://insights.sbomify.com/CVE-2019-5401/index.md)","id":"CVE-2019-5401","markdown":"https://insights.sbomify.com/CVE-2019-5401/index.md","name":"CVE-2019-5401","record":{"aliases":["GHSA-hx6f-cw8v-7979"],"analysis":{"component_type":"network_device","fix_type":"upgrade","impacts":["code_execution","security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"HP network switch","requires_auth":"high_privilege","summary":"An authenticated admin can inject XSS via configuration fields, potentially leading to code execution or security bypass on HP switches.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"hpe","cpe":[{"product":"hp2910al-48g_firmware","vendor":"hp"}],"cvss":{"score":4.8,"severity":"medium","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:H/UI:R/S:C/C:L/I:L/A:N","version":"3.0"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"A potential security vulnerability has been identified in HP2910al-48G version W.15.14.0016. The attack exploits an xss injection by setting the attack vector in one of the switch persistent configuration fields (management URL, location, contact). But admin privileges are required to configure these fields thereby reducing the likelihood of exploit. HPE Aruba has provided firmware updates to resolve the vulnerability in HP 2910-48G al Switch. Please update to W.15.14.0017.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":null,"headline":"Cross-site scripting in HP 2910-48G al Switch","id":"CVE-2019-5401","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"xss","year":"2019"},"n_packages":0,"n_references":1,"next":{"headline":"A remote authorization bypass vulnerability was discovered in HPE 3PAR StoreServ Management and Core Software Media version(s): prior to 3.5.0.1.","id":"CVE-2019-5402"},"packages":[],"prev":{"headline":"Auth bypass in HPE 3PAR Service Processor","id":"CVE-2019-5400"},"products":["HP 2910-48G al Switch"],"published":"2019-08-01","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-04","vendors":["HP"]},"summary":"An authenticated admin can inject XSS via configuration fields, potentially leading to code execution or security bypass on HP switches.","url":"https://insights.sbomify.com/CVE-2019-5401/"}