# CVE-2019-5414: Command Injection in kill-port


- **Severity:** High 8.1 (`CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 17 Mar 2019
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-pmv6-gf98-p3r5

## What is CVE-2019-5414?

CVE-2019-5414 is a high-severity vulnerability in kill-port, published on 17 Mar 2019. 

### Official description

If an attacker can control the port, which in itself is a very sensitive value, they can inject arbitrary OS commands due to the usage of the exec function in a third-party module kill-port < 1.3.2.

Weakness: CWE-78 (Improper Neutralization of Special Elements used in an OS Command), CWE-77 (Improper Neutralization of Special Elements used in a Command)

## Which versions are affected by CVE-2019-5414?

2 open source packages ship an affected version, including kill-port. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `kill-port` | npm | All versions | 1.3.2 |
| `kill-port` | npm | All versions | 1.3.2 |

Products: Kill-Port Project Kill-Port.

## How do I fix CVE-2019-5414?

Upgrade kill-port to 1.3.2 or later.

## Is CVE-2019-5414 being exploited?

There is no known exploitation of CVE-2019-5414 in the wild and no public exploit code.

Public exploit code:

- Fake repo (github_poc): https://github.com/crstaicu/CVE-2019-5414

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-5414 and fix it if it is affected.

What it is: CVE-2019-5414 is a high-severity vulnerability in kill-port, published on 17 Mar 2019. 
Exploitation: There is no known exploitation of CVE-2019-5414 in the wild and no public exploit code.

Affected packages and fixed versions:
- kill-port (npm): affected all versions; fixed in 1.3.2
- kill-port (npm): affected all versions; fixed in 1.3.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-5414/ (Markdown: https://insights.sbomify.com/CVE-2019-5414/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-5414
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-5414
- OSV: https://osv.dev/vulnerability/CVE-2019-5414

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-5414/
Summaries are generated and may contain mistakes; the official description above is the record.
