{"answers":{"affected":"2 open source packages ship an affected version, including serve. It affects 1 product.","exploited":"There is no known exploitation of CVE-2019-5417 in the wild and no public exploit code.","fix":"Upgrade serve to 7.1.3 or later.","what":"CVE-2019-5417 is a high-severity path traversal vulnerability in serve, published on 17 Mar 2019. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2019-5417 and fix it if it is affected.\n\nWhat it is: CVE-2019-5417 is a high-severity path traversal vulnerability in serve, published on 17 Mar 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2019-5417 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- serve (npm): affected all versions; fixed in 7.1.3\n- serve (npm): affected all versions; fixed in 7.1.3\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2019-5417/ (Markdown: https://insights.sbomify.com/CVE-2019-5417/index.md)","id":"CVE-2019-5417","markdown":"https://insights.sbomify.com/CVE-2019-5417/index.md","name":"CVE-2019-5417","record":{"aliases":["GHSA-xg75-3277-gvvj"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"Node.js static server","requires_auth":"none","summary":"Attackers can read arbitrary files on the remote server via path traversal in the serve npm package.","user_interaction":"not_required","vuln_class":"path_traversal"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"hackerone","cpe":[{"product":"serve","vendor":"zeit"}],"cvss":{"score":7.5,"severity":"high","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N","version":"3.0"},"cwes":[{"id":"CWE-22","name":"Improper Limitation of a Pathname to a Restricted Directory"}],"description":"A path traversal vulnerability in serve npm package version 7.0.1 allows the attackers to read content of arbitrary files on the remote server.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Directory Traversal in serve","id":"CVE-2019-5417","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"path_traversal","year":"2019"},"n_packages":2,"n_references":1,"next":{"headline":"Rails Ruby on Rails Path Traversal","id":"CVE-2019-5418"},"packages":[{"ecosystem":"npm","fixed":["7.1.3"],"introduced":["0"],"last_affected":[],"package":"serve","purl":null,"source":"GHSA-xg75-3277-gvvj"},{"ecosystem":"npm","fixed":["7.1.3"],"introduced":["0"],"last_affected":[],"package":"serve","purl":"pkg:npm/serve","source":"GHSA-xg75-3277-gvvj"}],"prev":{"headline":"Path Traversal in localhost-now","id":"CVE-2019-5416"},"products":["serve"],"published":"2019-03-17","related":[{"cvss_score":7.5,"headline":"Path Traversal in serve","id":"CVE-2019-5415","kev_date_added":null,"published":"2019-03-17"},{"cvss_score":6.5,"headline":"Directory Traversal in serve","id":"CVE-2018-3712","kev_date_added":null,"published":"2018-06-07"},{"cvss_score":5.3,"headline":"vercel/serve allows access to restricted files if filename is URL encoded.","id":"CVE-2018-3718","kev_date_added":null,"published":"2018-06-07"},{"cvss_score":5.3,"headline":"Information Exposure on Case Insensitive File Systems in serve","id":"CVE-2018-3809","kev_date_added":null,"published":"2018-06-01"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-04","vendors":["n/a"]},"summary":"Attackers can read arbitrary files on the remote server via path traversal in the serve npm package.","url":"https://insights.sbomify.com/CVE-2019-5417/"}