# CVE-2019-5417: Directory Traversal in serve

> Attackers can read arbitrary files on the remote server via path traversal in the serve npm package.

- **Severity:** High 7.5 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 17 Mar 2019
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-xg75-3277-gvvj

## What is CVE-2019-5417?

CVE-2019-5417 is a high-severity path traversal vulnerability in serve, published on 17 Mar 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

A path traversal vulnerability in serve npm package version 7.0.1 allows the attackers to read content of arbitrary files on the remote server.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2019-5417?

2 open source packages ship an affected version, including serve. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `serve` | npm | All versions | 7.1.3 |
| `serve` | npm | All versions | 7.1.3 |

Products: Zeit Serve.

## How do I fix CVE-2019-5417?

Upgrade serve to 7.1.3 or later.

## Is CVE-2019-5417 being exploited?

There is no known exploitation of CVE-2019-5417 in the wild and no public exploit code.

## Other vulnerabilities in serve

- [CVE-2019-5415](https://insights.sbomify.com/CVE-2019-5415/): Path Traversal in serve (high 7.5)
- [CVE-2018-3712](https://insights.sbomify.com/CVE-2018-3712/): Directory Traversal in serve (medium 6.5)
- [CVE-2018-3718](https://insights.sbomify.com/CVE-2018-3718/): vercel/serve allows access to restricted files if filename is URL encoded. (medium 5.3)
- [CVE-2018-3809](https://insights.sbomify.com/CVE-2018-3809/): Information Exposure on Case Insensitive File Systems in serve (medium 5.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-5417 and fix it if it is affected.

What it is: CVE-2019-5417 is a high-severity path traversal vulnerability in serve, published on 17 Mar 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2019-5417 in the wild and no public exploit code.

Affected packages and fixed versions:
- serve (npm): affected all versions; fixed in 7.1.3
- serve (npm): affected all versions; fixed in 7.1.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-5417/ (Markdown: https://insights.sbomify.com/CVE-2019-5417/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-5417
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-5417
- OSV: https://osv.dev/vulnerability/CVE-2019-5417

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-5417/
Summaries are generated and may contain mistakes; the official description above is the record.
