CVE-2019-5419 Denial of Service Vulnerability in Action View
Attackers can cause a denial of service in Ruby on Rails by sending specially crafted accept headers, leading to high CPU usage and server unresponsiveness.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2019-5419?
CVE-2019-5419 is a high-severity denial of service vulnerability in Debian Debian Linux, published on 27 Mar 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
There is a possible denial of service vulnerability in Action View (Rails) <5.2.2.1, <5.1.6.2, <5.0.7.2, <4.2.11.1 where specially crafted accept headers can cause action view to consume 100% cpu and make the server unresponsive.
Which versions are affected by CVE-2019-5419?
10 open source packages ship an affected version, including actionview. It affects 6 products.
| Package | Affected | Fixed in |
|---|---|---|
actionview RubyGems | From 4.0.0 | 4.2.11.1 |
actionview RubyGems | From 4.0.0 | 4.2.11.1 |
actionview RubyGems | From 5.0.0 | 5.0.7.2 |
actionview RubyGems | From 5.0.0 | 5.0.7.2 |
actionview RubyGems | From 5.1.0 | 5.1.6.2 |
actionview RubyGems | From 5.1.0 | 5.1.6.2 |
4 more packages
actionview RubyGems | From 5.2.0 | 5.2.2.1 |
actionview RubyGems | From 5.2.0 | 5.2.2.1 |
actionview RubyGems | From 6.0.0.beta1 | 6.0.0.beta3 |
actionview RubyGems | From 6.0.0.beta1 | 6.0.0.beta3 |
Products include Debian Debian Linux, Fedoraproject Fedora, Opensuse Leap, Redhat Cloudforms, Redhat Software Collections, Rubyonrails Rails.
How do I fix CVE-2019-5419?
Upgrade actionview to a fixed version for your release line: 4.2.11.1, 5.0.7.2, 5.1.6.2 or 5.2.2.1.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2019-5419 being exploited?
There is no known exploitation of CVE-2019-5419 in the wild and no public exploit code.
Other vulnerabilities in Debian Debian Linux
Sources
Also known as DEBIAN-CVE-2019-5419, GHSA-m63j-wh5w-c252, UBUNTU-CVE-2019-5419.