# CVE-2019-5419: Denial of Service Vulnerability in Action View

> Attackers can cause a denial of service in Ruby on Rails by sending specially crafted accept headers, leading to high CPU usage and server unresponsiveness.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 27 Mar 2019
- **Updated:** 4 Aug 2024
- **Also known as:** DEBIAN-CVE-2019-5419, GHSA-m63j-wh5w-c252, UBUNTU-CVE-2019-5419

## What is CVE-2019-5419?

CVE-2019-5419 is a high-severity denial of service vulnerability in Debian Debian Linux, published on 27 Mar 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

There is a possible denial of service vulnerability in Action View (Rails) <5.2.2.1, <5.1.6.2, <5.0.7.2, <4.2.11.1 where specially crafted accept headers can cause action view to consume 100% cpu and make the server unresponsive.

Weakness: CWE-770 (Allocation of Resources Without Limits or Throttling), CWE-400 (Uncontrolled Resource Consumption)

## Which versions are affected by CVE-2019-5419?

10 open source packages ship an affected version, including actionview. It affects 6 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `actionview` | RubyGems | From 4.0.0 | 4.2.11.1 |
| `actionview` | RubyGems | From 4.0.0 | 4.2.11.1 |
| `actionview` | RubyGems | From 5.0.0 | 5.0.7.2 |
| `actionview` | RubyGems | From 5.0.0 | 5.0.7.2 |
| `actionview` | RubyGems | From 5.1.0 | 5.1.6.2 |
| `actionview` | RubyGems | From 5.1.0 | 5.1.6.2 |
| `actionview` | RubyGems | From 5.2.0 | 5.2.2.1 |
| `actionview` | RubyGems | From 5.2.0 | 5.2.2.1 |
| `actionview` | RubyGems | From 6.0.0.beta1 | 6.0.0.beta3 |
| `actionview` | RubyGems | From 6.0.0.beta1 | 6.0.0.beta3 |

Products: Debian Debian Linux, Fedoraproject Fedora, Opensuse Leap, Redhat Cloudforms, Redhat Software Collections, Rubyonrails Rails.

## How do I fix CVE-2019-5419?

Upgrade actionview to a fixed version for your release line: 4.2.11.1, 5.0.7.2, 5.1.6.2 or 5.2.2.1.

## Is CVE-2019-5419 being exploited?

There is no known exploitation of CVE-2019-5419 in the wild and no public exploit code.

## Other vulnerabilities in Debian Debian Linux

- [CVE-2015-3306](https://insights.sbomify.com/CVE-2015-3306/): ProFTPD Improper Access Control (critical 10.0, exploited in the wild)
- [CVE-2025-49113](https://insights.sbomify.com/CVE-2025-49113/): RoundCube Webmail Deserialization of Untrusted Data (critical 9.9, exploited in the wild)
- [CVE-2026-24061](https://insights.sbomify.com/CVE-2026-24061/): GNU InetUtils Argument Injection (critical 9.8, exploited in the wild)
- [CVE-2025-39682](https://insights.sbomify.com/CVE-2025-39682/): Linux Kernel Improper Check for Unusual or Exceptional Conditions (critical 9.8, exploited in the wild)
- [CVE-2024-9680](https://insights.sbomify.com/CVE-2024-9680/): Mozilla Firefox Use-After-Free (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-5419 and fix it if it is affected.

What it is: CVE-2019-5419 is a high-severity denial of service vulnerability in Debian Debian Linux, published on 27 Mar 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2019-5419 in the wild and no public exploit code.

Affected packages and fixed versions:
- actionview (RubyGems): affected from 4.0.0; fixed in 4.2.11.1
- actionview (RubyGems): affected from 4.0.0; fixed in 4.2.11.1
- actionview (RubyGems): affected from 5.0.0; fixed in 5.0.7.2
- actionview (RubyGems): affected from 5.0.0; fixed in 5.0.7.2
- actionview (RubyGems): affected from 5.1.0; fixed in 5.1.6.2
- actionview (RubyGems): affected from 5.1.0; fixed in 5.1.6.2
- actionview (RubyGems): affected from 5.2.0; fixed in 5.2.2.1
- actionview (RubyGems): affected from 5.2.0; fixed in 5.2.2.1
- actionview (RubyGems): affected from 6.0.0.beta1; fixed in 6.0.0.beta3
- actionview (RubyGems): affected from 6.0.0.beta1; fixed in 6.0.0.beta3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-5419/ (Markdown: https://insights.sbomify.com/CVE-2019-5419/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-5419
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-5419
- OSV: https://osv.dev/vulnerability/CVE-2019-5419

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-5419/
Summaries are generated and may contain mistakes; the official description above is the record.
