CVE-2019-5421 devise Time-of-check Time-of-use Race Condition vulnerability

Critical 9.8 Published Updated

A race condition in the Devise lockable module allows attackers to bypass brute-force protection mechanisms by sending concurrent requests.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2019-5421?

CVE-2019-5421 is a critical vulnerability in Plataformatec Devise ruby gem, published on 3 Apr 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

Plataformatec Devise version 4.5.0 and earlier, using the lockable module contains a CWE-367 vulnerability in The `Devise::Models::Lockable` class, more specifically at the `#increment_failed_attempts` method. File location: lib/devise/models/lockable.rb that can result in Multiple concurrent requests can prevent an attacker from being blocked on brute force attacks. This attack appear to be exploitable via Network connectivity - brute force attacks. This vulnerability appears to have been fixed in 4.6.0 and later.

Weakness: CWE-307, CWE-367

Which versions are affected by CVE-2019-5421?

2 open source packages ship an affected version, including devise. It affects 1 product.

PackageAffectedFixed in
devise RubyGemsAll versions4.6.0
devise RubyGemsAll versions4.6.0

Products include Plataformatec Devise.

How do I fix CVE-2019-5421?

Upgrade devise to 4.6.0 or later.

Is CVE-2019-5421 being exploited?

There is no known exploitation of CVE-2019-5421 in the wild and no public exploit code.

Sources

Also known as DEBIAN-CVE-2019-5421, GHSA-73rf-6mrf-759q, UBUNTU-CVE-2019-5421.

Is CVE-2019-5421 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free