{"answers":{"affected":"2 open source packages ship an affected version, including devise. It affects 1 product.","exploited":"There is no known exploitation of CVE-2019-5421 in the wild and no public exploit code.","fix":"Upgrade devise to 4.6.0 or later.","what":"CVE-2019-5421 is a critical vulnerability in Plataformatec Devise ruby gem, published on 3 Apr 2019. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2019-5421 and fix it if it is affected.\n\nWhat it is: CVE-2019-5421 is a critical vulnerability in Plataformatec Devise ruby gem, published on 3 Apr 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2019-5421 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- devise (RubyGems): affected all versions; fixed in 4.6.0\n- devise (RubyGems): affected all versions; fixed in 4.6.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2019-5421/ (Markdown: https://insights.sbomify.com/CVE-2019-5421/index.md)","id":"CVE-2019-5421","markdown":"https://insights.sbomify.com/CVE-2019-5421/index.md","name":"CVE-2019-5421","record":{"aliases":["DEBIAN-CVE-2019-5421","GHSA-73rf-6mrf-759q","UBUNTU-CVE-2019-5421"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"Ruby authentication library","requires_auth":"none","summary":"A race condition in the Devise lockable module allows attackers to bypass brute-force protection mechanisms by sending concurrent requests.","user_interaction":"not_required","vuln_class":"race_condition"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"hackerone","cpe":[{"product":"devise","vendor":"plataformatec"}],"cvss":{"score":9.8,"severity":"critical","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-307","name":"Improper Restriction of Excessive Authentication Attempts"},{"id":"CWE-367","name":"Time-of-check Time-of-use (TOCTOU) Race Condition"}],"description":"Plataformatec Devise version 4.5.0 and earlier, using the lockable module contains a CWE-367 vulnerability in The `Devise::Models::Lockable` class, more specifically at the `#increment_failed_attempts` method. File location: lib/devise/models/lockable.rb that can result in Multiple concurrent requests can prevent an attacker from being blocked on brute force attacks. This attack appear to be exploitable via Network connectivity - brute force attacks. This vulnerability appears to have been fixed in 4.6.0 and later.","ecosystems":["RubyGems"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"devise Time-of-check Time-of-use Race Condition vulnerability","id":"CVE-2019-5421","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"RubyGems","product":null,"products":[],"type":"race_condition","year":"2019"},"n_packages":2,"n_references":2,"next":{"headline":"Cross-Site Scripting in buttle","id":"CVE-2019-5422"},"packages":[{"ecosystem":"RubyGems","fixed":["4.6.0"],"introduced":["0"],"last_affected":[],"package":"devise","purl":null,"source":"GHSA-73rf-6mrf-759q"},{"ecosystem":"RubyGems","fixed":["4.6.0"],"introduced":["0"],"last_affected":[],"package":"devise","purl":"pkg:gem/devise","source":"GHSA-73rf-6mrf-759q"}],"prev":{"headline":"Use of Insufficiently Random Values in Railties Allows Remote Code Execution","id":"CVE-2019-5420"},"products":["Devise ruby gem"],"published":"2019-04-03","related":[{"cvss_score":5.3,"headline":"Authentication Bypass in Devise","id":"CVE-2019-16109","kev_date_added":null,"published":"2019-09-08"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-04","vendors":["Plataformatec"]},"summary":"A race condition in the Devise lockable module allows attackers to bypass brute-force protection mechanisms by sending concurrent requests.","url":"https://insights.sbomify.com/CVE-2019-5421/"}