# CVE-2019-5423: Path Traversal in http-live-simulator

> A remote attacker can access arbitrary files on the file system via a path traversal vulnerability in the http-live-simulator npm package.

- **Severity:** High 7.5 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 3 Apr 2019
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-2hhw-p8mg-jrm6

## What is CVE-2019-5423?

CVE-2019-5423 is a high-severity path traversal vulnerability in Npm, Inc. http-live-simulator, published on 3 Apr 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Path traversal vulnerability in http-live-simulator npm package version 1.0.5 allows arbitrary path to be accessed on the file system by a remote attacker.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2019-5423?

2 open source packages ship an affected version, including http-live-simulator. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `http-live-simulator` | npm | All versions | 1.0.6 |
| `http-live-simulator` | npm | All versions | 1.0.6 |

Products: Http-Live-Simulator Project Http-Live-Simulator.

## How do I fix CVE-2019-5423?

Upgrade http-live-simulator to 1.0.6 or later.

## Is CVE-2019-5423 being exploited?

There is no known exploitation of CVE-2019-5423 in the wild and no public exploit code.

## Other vulnerabilities in Npm, Inc. http-live-simulator

- [CVE-2018-16479](https://insights.sbomify.com/CVE-2018-16479/): Path Traversal in http-live-simulator (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-5423 and fix it if it is affected.

What it is: CVE-2019-5423 is a high-severity path traversal vulnerability in Npm, Inc. http-live-simulator, published on 3 Apr 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2019-5423 in the wild and no public exploit code.

Affected packages and fixed versions:
- http-live-simulator (npm): affected all versions; fixed in 1.0.6
- http-live-simulator (npm): affected all versions; fixed in 1.0.6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-5423/ (Markdown: https://insights.sbomify.com/CVE-2019-5423/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-5423
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-5423
- OSV: https://osv.dev/vulnerability/CVE-2019-5423

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-5423/
Summaries are generated and may contain mistakes; the official description above is the record.
