# CVE-2019-5427: Billion laughs attack in c3p0

> An attacker can cause denial of service via a billion laughs attack in c3p0 due to missing protections against recursive entity expansion in XML configuration.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 22 Apr 2019
- **Updated:** 4 Aug 2024
- **Also known as:** DEBIAN-CVE-2019-5427, GHSA-84p2-vf58-xhxv, UBUNTU-CVE-2019-5427, USN-5293-1, USN-5293-2, USN-7571-1, openSUSE-SU-2024:11961-1

## What is CVE-2019-5427?

CVE-2019-5427 is a high-severity vulnerability in Fedoraproject Fedora, published on 22 Apr 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

c3p0 version < 0.9.5.4 may be exploited by a billion laughs attack when loading XML configuration due to missing protections against recursive entity expansion when loading configuration.

Weakness: CWE-776 (Improper Restriction of Recursive Entity References in DTDs)

## Which versions are affected by CVE-2019-5427?

2 open source packages ship an affected version, including com.mchange:c3p0. It affects 11 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `com.mchange:c3p0` | Maven | All versions | 0.9.5.4 |
| `com.mchange:c3p0` | Maven | All versions | 0.9.5.4 |
| `c3p0` | openSUSE:Tumbleweed | All versions | 0.9.5.5-2.1 |

Products: Fedoraproject Fedora, Mchange C3p0, Oracle Communications Ip Service Activator, Oracle Communications Session Route Manager, Oracle Documaker, Oracle Enterprise Manager Base Platform, Oracle Enterprise Manager Ops Center, Oracle Flexcube Private Banking, Oracle Hyperion Infrastructure Technology, Oracle Retail Xstore Point of Service, Oracle Webcenter Sites.

## How do I fix CVE-2019-5427?

Upgrade com.mchange:c3p0 to 0.9.5.4 or later.

## Is CVE-2019-5427 being exploited?

There is no known exploitation of CVE-2019-5427 in the wild and no public exploit code.

Public exploit code:

- version between CVE-2018-20433 and CVE-2019-5427 (github_poc): https://github.com/shanika04/cp30_XXE_partial_fix

## Other vulnerabilities in Fedoraproject Fedora

- [CVE-2024-4577](https://insights.sbomify.com/CVE-2024-4577/): PHP-CGI OS Command Injection (critical 9.8, exploited in the wild)
- [CVE-2021-39226](https://insights.sbomify.com/CVE-2021-39226/): Grafana Authentication Bypass (critical 9.8, exploited in the wild)
- [CVE-2019-5544](https://insights.sbomify.com/CVE-2019-5544/): VMware ESXi and Horizon DaaS OpenSLP Heap-Based Buffer Overflow (critical 9.8, exploited in the wild)
- [CVE-2024-4947](https://insights.sbomify.com/CVE-2024-4947/): Google Chromium V8 Type Confusion (critical 9.6, exploited in the wild)
- [CVE-2024-4671](https://insights.sbomify.com/CVE-2024-4671/): Google Chromium Visuals Use-After-Free (critical 9.6, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-5427 and fix it if it is affected.

What it is: CVE-2019-5427 is a high-severity vulnerability in Fedoraproject Fedora, published on 22 Apr 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2019-5427 in the wild and no public exploit code.

Affected packages and fixed versions:
- com.mchange:c3p0 (Maven): affected all versions; fixed in 0.9.5.4
- com.mchange:c3p0 (Maven): affected all versions; fixed in 0.9.5.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-5427/ (Markdown: https://insights.sbomify.com/CVE-2019-5427/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-5427
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-5427
- OSV: https://osv.dev/vulnerability/CVE-2019-5427

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-5427/
Summaries are generated and may contain mistakes; the official description above is the record.
