# CVE-2019-5432: Improper Input Validation and Buffer Over-read in mqtt-packet

> A malformed MQTT Subscribe packet crashes MQTT brokers using the mqtt-packet library, causing a denial of service.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 6 May 2019
- **Updated:** 4 Aug 2024
- **Also known as:** DEBIAN-CVE-2019-5432, GHSA-wv67-9jq7-8r69, UBUNTU-CVE-2019-5432

## What is CVE-2019-5432?

CVE-2019-5432 is a high-severity denial of service vulnerability in mqtt-packet, published on 6 May 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

A specifically malformed MQTT Subscribe packet crashes MQTT Brokers using the mqtt-packet module versions < 3.5.1, 4.0.0 - 4.1.3, 5.0.0 - 5.6.1, 6.0.0 - 6.1.2 for decoding.

Weakness: CWE-125 (Out-of-bounds Read), CWE-126 (Buffer Over-read)

## Which versions are affected by CVE-2019-5432?

8 open source packages ship an affected version, including mqtt-packet. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `mqtt-packet` | npm | All versions | 3.5.1 |
| `mqtt-packet` | npm | All versions | 3.5.1 |
| `mqtt-packet` | npm | From 4.0.0 | 4.1.3 |
| `mqtt-packet` | npm | From 4.0.0 | 4.1.3 |
| `mqtt-packet` | npm | From 5.0.0 | 5.6.1 |
| `mqtt-packet` | npm | From 5.0.0 | 5.6.1 |
| `mqtt-packet` | npm | From 6.0.0 | 6.1.2 |
| `mqtt-packet` | npm | From 6.0.0 | 6.1.2 |

Products: Mqtt-Packet Project Mqtt-Packet.

## How do I fix CVE-2019-5432?

Upgrade mqtt-packet to a fixed version for your release line: 3.5.1, 4.1.3, 5.6.1 or 6.1.2.

## Is CVE-2019-5432 being exploited?

There is no known exploitation of CVE-2019-5432 in the wild and no public exploit code.

## Other vulnerabilities in mqtt-packet

- [CVE-2016-10523](https://insights.sbomify.com/CVE-2016-10523/): Denial of Service in mqtt-packet (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-5432 and fix it if it is affected.

What it is: CVE-2019-5432 is a high-severity denial of service vulnerability in mqtt-packet, published on 6 May 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2019-5432 in the wild and no public exploit code.

Affected packages and fixed versions:
- mqtt-packet (npm): affected all versions; fixed in 3.5.1
- mqtt-packet (npm): affected all versions; fixed in 3.5.1
- mqtt-packet (npm): affected from 4.0.0; fixed in 4.1.3
- mqtt-packet (npm): affected from 4.0.0; fixed in 4.1.3
- mqtt-packet (npm): affected from 5.0.0; fixed in 5.6.1
- mqtt-packet (npm): affected from 5.0.0; fixed in 5.6.1
- mqtt-packet (npm): affected from 6.0.0; fixed in 6.1.2
- mqtt-packet (npm): affected from 6.0.0; fixed in 6.1.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-5432/ (Markdown: https://insights.sbomify.com/CVE-2019-5432/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-5432
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-5432
- OSV: https://osv.dev/vulnerability/CVE-2019-5432

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-5432/
Summaries are generated and may contain mistakes; the official description above is the record.
