CVE-2019-5437 Unauthorized File Access in harp

Medium 5.3 Published Updated

Attackers can access ignored files via directory listing in the harp npm module, exposing sensitive data.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2019-5437?

CVE-2019-5437 is a medium-severity vulnerability in harp, published on 10 May 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

Information exposure through the directory listing in npm's harp module allows to access files that are supposed to be ignored according to the harp server rules.Vulnerable versions are <= 0.29.0 and no fix was applied to our knowledge.

Weakness: CWE-200, CWE-548

Which versions are affected by CVE-2019-5437?

2 open source packages ship an affected version, including harp. It affects 1 product.

PackageAffectedFixed in
harp npmAll versions0.40.2
harp npmAll versions0.40.2

Products include Harpjs Harp.

How do I fix CVE-2019-5437?

Upgrade harp to 0.40.2 or later.

Is CVE-2019-5437 being exploited?

There is no known exploitation of CVE-2019-5437 in the wild and no public exploit code.

Sources

Also known as GHSA-46hv-7769-j7rx.

Is CVE-2019-5437 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free