# CVE-2019-5437: Unauthorized File Access in harp

> Attackers can access ignored files via directory listing in the harp npm module, exposing sensitive data.

- **Severity:** Medium 5.3 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 10 May 2019
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-46hv-7769-j7rx

## What is CVE-2019-5437?

CVE-2019-5437 is a medium-severity vulnerability in harp, published on 10 May 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Information exposure through the directory listing in npm's harp module allows to access files that are supposed to be ignored according to the harp server rules.Vulnerable versions are <= 0.29.0 and no fix was applied to our knowledge.

Weakness: CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor), CWE-548 (Exposure of Information Through Directory Listing)

## Which versions are affected by CVE-2019-5437?

2 open source packages ship an affected version, including harp. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `harp` | npm | All versions | 0.40.2 |
| `harp` | npm | All versions | 0.40.2 |

Products: Harpjs Harp.

## How do I fix CVE-2019-5437?

Upgrade harp to 0.40.2 or later.

## Is CVE-2019-5437 being exploited?

There is no known exploitation of CVE-2019-5437 in the wild and no public exploit code.

## Other vulnerabilities in harp

- [CVE-2019-5438](https://insights.sbomify.com/CVE-2019-5438/): Unauthorized File Access in harp (medium 5.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-5437 and fix it if it is affected.

What it is: CVE-2019-5437 is a medium-severity vulnerability in harp, published on 10 May 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2019-5437 in the wild and no public exploit code.

Affected packages and fixed versions:
- harp (npm): affected all versions; fixed in 0.40.2
- harp (npm): affected all versions; fixed in 0.40.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-5437/ (Markdown: https://insights.sbomify.com/CVE-2019-5437/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-5437
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-5437
- OSV: https://osv.dev/vulnerability/CVE-2019-5437

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-5437/
Summaries are generated and may contain mistakes; the official description above is the record.
