{"answers":{"affected":"2 open source packages ship an affected version, including yarn. It affects 1 product.","exploited":"There is no known exploitation of CVE-2019-5448 in the wild and no public exploit code.","fix":"Upgrade yarn to 1.17.3 or later.","what":"CVE-2019-5448 is a high-severity vulnerability in yarn, published on 30 Jul 2019. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2019-5448 and fix it if it is affected.\n\nWhat it is: CVE-2019-5448 is a high-severity vulnerability in yarn, published on 30 Jul 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2019-5448 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- yarn (npm): affected all versions; fixed in 1.17.3\n- yarn (npm): affected all versions; fixed in 1.17.3\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2019-5448/ (Markdown: https://insights.sbomify.com/CVE-2019-5448/index.md)","id":"CVE-2019-5448","markdown":"https://insights.sbomify.com/CVE-2019-5448/index.md","name":"CVE-2019-5448","record":{"aliases":["DEBIAN-CVE-2019-5448","GHSA-wqfc-cr59-h64p"],"analysis":{"component_type":"developer_tool","fix_type":"upgrade","impacts":["data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"Yarn package manager","requires_auth":"none","summary":"Attackers can intercept unencrypted authentication tokens sent over HTTP during Yarn package installation, exposing sensitive credentials.","user_interaction":"not_required","vuln_class":"information_disclosure"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"hackerone","cpe":[{"product":"yarn","vendor":"yarnpkg"}],"cvss":{"score":8.1,"severity":"high","source":"nvd","vector":"CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-319","name":"Cleartext Transmission of Sensitive Information"},{"id":"CWE-311","name":"Missing Encryption of Sensitive Data"}],"description":"Yarn before 1.17.3 is vulnerable to Missing Encryption of Sensitive Data due to HTTP URLs in lockfile causing unencrypted authentication data to be sent over the network.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Missing Encryption of Sensitive Data in yarn","id":"CVE-2019-5448","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"information_disclosure","year":"2019"},"n_packages":2,"n_references":3,"next":{"headline":"Information disclosure in Nextcloud Server","id":"CVE-2019-5449"},"packages":[{"ecosystem":"npm","fixed":["1.17.3"],"introduced":["0"],"last_affected":[],"package":"yarn","purl":null,"source":"GHSA-wqfc-cr59-h64p"},{"ecosystem":"npm","fixed":["1.17.3"],"introduced":["0"],"last_affected":[],"package":"yarn","purl":"pkg:npm/yarn","source":"GHSA-wqfc-cr59-h64p"}],"prev":{"headline":"Path Traversal in http-file-server","id":"CVE-2019-5447"},"products":["yarn"],"published":"2019-07-30","related":[{"cvss_score":7.8,"headline":"Yarn Improper link resolution before file access (Link Following)","id":"CVE-2019-10773","kev_date_added":null,"published":"2019-12-16"},{"cvss_score":7.7,"headline":"Yarn: untrusted search path","id":"CVE-2021-4435","kev_date_added":null,"published":"2024-02-04"},{"cvss_score":7.5,"headline":"Path Traversal in Yarn","id":"CVE-2020-8131","kev_date_added":null,"published":"2020-02-24"},{"cvss_score":5.9,"headline":"TOCTOU Race Condition in Yarn","id":"CVE-2019-15608","kev_date_added":null,"published":"2020-03-15"},{"cvss_score":5.3,"headline":"yarnpkg Yarn hosted-git-resolver.js explodeHostedGitFragment redos","id":"CVE-2025-8262","kev_date_added":null,"published":"2025-07-28"},{"cvss_score":4.8,"headline":"yarnpkg Yarn request-manager.js setOptions redos","id":"CVE-2025-9308","kev_date_added":null,"published":"2025-08-21"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-04","vendors":["yarn"]},"summary":"Attackers can intercept unencrypted authentication tokens sent over HTTP during Yarn package installation, exposing sensitive credentials.","url":"https://insights.sbomify.com/CVE-2019-5448/"}