# CVE-2019-5448: Missing Encryption of Sensitive Data in yarn

> Attackers can intercept unencrypted authentication tokens sent over HTTP during Yarn package installation, exposing sensitive credentials.

- **Severity:** High 8.1 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 30 Jul 2019
- **Updated:** 4 Aug 2024
- **Also known as:** DEBIAN-CVE-2019-5448, GHSA-wqfc-cr59-h64p

## What is CVE-2019-5448?

CVE-2019-5448 is a high-severity vulnerability in yarn, published on 30 Jul 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Yarn before 1.17.3 is vulnerable to Missing Encryption of Sensitive Data due to HTTP URLs in lockfile causing unencrypted authentication data to be sent over the network.

Weakness: CWE-319 (Cleartext Transmission of Sensitive Information), CWE-311 (Missing Encryption of Sensitive Data)

## Which versions are affected by CVE-2019-5448?

2 open source packages ship an affected version, including yarn. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `yarn` | npm | All versions | 1.17.3 |
| `yarn` | npm | All versions | 1.17.3 |

Products: Yarnpkg Yarn.

## How do I fix CVE-2019-5448?

Upgrade yarn to 1.17.3 or later.

## Is CVE-2019-5448 being exploited?

There is no known exploitation of CVE-2019-5448 in the wild and no public exploit code.

## Other vulnerabilities in yarn

- [CVE-2019-10773](https://insights.sbomify.com/CVE-2019-10773/): Yarn Improper link resolution before file access (Link Following) (high 7.8)
- [CVE-2021-4435](https://insights.sbomify.com/CVE-2021-4435/): Yarn: untrusted search path (high 7.7)
- [CVE-2020-8131](https://insights.sbomify.com/CVE-2020-8131/): Path Traversal in Yarn (high 7.5)
- [CVE-2019-15608](https://insights.sbomify.com/CVE-2019-15608/): TOCTOU Race Condition in Yarn (medium 5.9)
- [CVE-2025-8262](https://insights.sbomify.com/CVE-2025-8262/): yarnpkg Yarn hosted-git-resolver.js explodeHostedGitFragment redos (medium 5.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-5448 and fix it if it is affected.

What it is: CVE-2019-5448 is a high-severity vulnerability in yarn, published on 30 Jul 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2019-5448 in the wild and no public exploit code.

Affected packages and fixed versions:
- yarn (npm): affected all versions; fixed in 1.17.3
- yarn (npm): affected all versions; fixed in 1.17.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-5448/ (Markdown: https://insights.sbomify.com/CVE-2019-5448/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-5448
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-5448
- OSV: https://osv.dev/vulnerability/CVE-2019-5448

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-5448/
Summaries are generated and may contain mistakes; the official description above is the record.
