# CVE-2019-5475: OS Command Injection in Nexus Yum Repository Plugin

> Remote code execution in Nexus Repository Manager via command injection in the Yum Repository Plugin when processing configuration data.

- **Severity:** High 8.8 (`CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 3 Sep 2019
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-g5m7-57ph-j6p8

## What is CVE-2019-5475?

CVE-2019-5475 is a high-severity command injection vulnerability in Sonatype Nexus Repository Manager, published on 3 Sep 2019. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

The Nexus Yum Repository Plugin in v2 is vulnerable to Remote Code Execution when instances using CommandLineExecutor.java are supplied vulnerable data, such as the Yum Configuration Capability.

Weakness: CWE-78 (Improper Neutralization of Special Elements used in an OS Command)

## Which versions are affected by CVE-2019-5475?

2 open source packages ship an affected version, including org.sonatype.nexus.plugins:nexus-yum-repository-plugin. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.sonatype.nexus.plugins:nexus-yum-repository-plugin` | Maven | All versions | 2.14.14 |
| `org.sonatype.nexus.plugins:nexus-yum-repository-plugin` | Maven | All versions | 2.14.14 |

Products: Sonatype Nexus Repository Manager.

## How do I fix CVE-2019-5475?

Upgrade org.sonatype.nexus.plugins:nexus-yum-repository-plugin to 2.14.14 or later.

## Is CVE-2019-5475 being exploited?

There is no known exploitation of CVE-2019-5475 in the wild and no public exploit code.

Public exploit code:

- https://github.com/jaychouzzk/CVE-2019-5475-Nexus-Repository-Manager- (github_poc): https://github.com/jaychouzzk/CVE-2019-5475-Nexus-Repository-Manager-
- CVE-2019-5475 靶场： RCE 命令注入漏洞 (github_poc): https://github.com/EXP-Docs/CVE-2019-5475
- CVE-2019-5475-EXP 【Nexus Repository Manager 2.x远程命令执行漏洞】 (github_poc): https://github.com/rabbitmask/CVE-2019-5475-EXP

## Other vulnerabilities in Sonatype Nexus Repository Manager

- [CVE-2019-7238](https://insights.sbomify.com/CVE-2019-7238/): Sonatype Nexus Repository Manager Incorrect Access Control (critical 9.8, exploited in the wild)
- [CVE-2019-9629](https://insights.sbomify.com/CVE-2019-9629/): Hardcoded credentials in n/a (critical 9.8)
- [CVE-2017-17717](https://insights.sbomify.com/CVE-2017-17717/): Hardcoded credentials in n/a (critical 9.8)
- [CVE-2026-3199](https://insights.sbomify.com/CVE-2026-3199/): Nexus Repository 3 - Authenticated Remote Code Execution via Task Property Injection (critical 9.4)
- [CVE-2026-5189](https://insights.sbomify.com/CVE-2026-5189/): Nexus Repository 3 - Hardcoded Credential in Internal Database Component (critical 9.2)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-5475 and fix it if it is affected.

What it is: CVE-2019-5475 is a high-severity command injection vulnerability in Sonatype Nexus Repository Manager, published on 3 Sep 2019. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2019-5475 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.sonatype.nexus.plugins:nexus-yum-repository-plugin (Maven): affected all versions; fixed in 2.14.14
- org.sonatype.nexus.plugins:nexus-yum-repository-plugin (Maven): affected all versions; fixed in 2.14.14

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-5475/ (Markdown: https://insights.sbomify.com/CVE-2019-5475/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-5475
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-5475
- OSV: https://osv.dev/vulnerability/CVE-2019-5475

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-5475/
Summaries are generated and may contain mistakes; the official description above is the record.
