# CVE-2019-5477: Nokogiri Command Injection Vulnerability

> Command injection in Nokogiri allows code execution via unsafe input to an undocumented tokenizer method, requiring specific usage patterns.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 16 Aug 2019
- **Updated:** 4 Aug 2024
- **Also known as:** DEBIAN-CVE-2019-5477, DLA-1933-1, DLA-3150-1, GHSA-cr5j-953j-xw5p, UBUNTU-CVE-2019-5477, USN-4175-1

## What is CVE-2019-5477?

CVE-2019-5477 is a critical command injection vulnerability in Canonical Ubuntu Linux, published on 16 Aug 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

A command injection vulnerability in Nokogiri v1.10.3 and earlier allows commands to be executed in a subprocess via Ruby's `Kernel.open` method. Processes are vulnerable only if the undocumented method `Nokogiri::CSS::Tokenizer#load_file` is being called with unsafe user input as the filename. This vulnerability appears in code generated by the Rexical gem versions v1.0.6 and earlier. Rexical is used by Nokogiri to generate lexical scanner code for parsing CSS queries. The underlying vulnerability was addressed in Rexical v1.0.7 and Nokogiri upgraded to this version of Rexical in Nokogiri v1.10.4.

Weakness: CWE-78 (Improper Neutralization of Special Elements used in an OS Command)

## Which versions are affected by CVE-2019-5477?

4 open source packages ship an affected version, including nokogiri and rexical. It affects 3 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `nokogiri` | RubyGems | All versions | 1.10.4 |
| `nokogiri` | RubyGems | All versions | 1.10.4 |
| `rexical` | RubyGems | All versions | 1.0.7 |
| `rexical` | RubyGems | All versions | 1.0.7 |

Products: Canonical Ubuntu Linux, Debian Debian Linux, Nokogiri Nokogiri.

## How do I fix CVE-2019-5477?

Upgrade nokogiri to 1.10.4 or later.

## Is CVE-2019-5477 being exploited?

There is no known exploitation of CVE-2019-5477 in the wild and no public exploit code.

## Other vulnerabilities in Canonical Ubuntu Linux

- [CVE-2020-11651](https://insights.sbomify.com/CVE-2020-11651/): SaltStack Salt Authentication Bypass (critical 9.8, exploited in the wild)
- [CVE-2020-7247](https://insights.sbomify.com/CVE-2020-7247/): OpenSMTPD Remote Code Execution (critical 9.8, exploited in the wild)
- [CVE-2019-16928](https://insights.sbomify.com/CVE-2019-16928/): Exim Out-of-bounds Write (critical 9.8, exploited in the wild)
- [CVE-2018-6789](https://insights.sbomify.com/CVE-2018-6789/): Exim Buffer Overflow (critical 9.8, exploited in the wild)
- [CVE-2015-2590](https://insights.sbomify.com/CVE-2015-2590/): Oracle Java SE and Java SE Embedded Remote Code Execution (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-5477 and fix it if it is affected.

What it is: CVE-2019-5477 is a critical command injection vulnerability in Canonical Ubuntu Linux, published on 16 Aug 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2019-5477 in the wild and no public exploit code.

Affected packages and fixed versions:
- nokogiri (RubyGems): affected all versions; fixed in 1.10.4
- nokogiri (RubyGems): affected all versions; fixed in 1.10.4
- rexical (RubyGems): affected all versions; fixed in 1.0.7
- rexical (RubyGems): affected all versions; fixed in 1.0.7

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-5477/ (Markdown: https://insights.sbomify.com/CVE-2019-5477/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-5477
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-5477
- OSV: https://osv.dev/vulnerability/CVE-2019-5477

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-5477/
Summaries are generated and may contain mistakes; the official description above is the record.
