{"answers":{"affected":"2 open source packages ship an affected version, including larvitbase-api. It affects 1 product.","exploited":"There is no known exploitation of CVE-2019-5479 in the wild and no public exploit code.","fix":"Upgrade larvitbase-api to 0.5.5 or later.","what":"CVE-2019-5479 is a high-severity code injection vulnerability in larvitbase-api, published on 3 Sep 2019. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2019-5479 and fix it if it is affected.\n\nWhat it is: CVE-2019-5479 is a high-severity code injection vulnerability in larvitbase-api, published on 3 Sep 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2019-5479 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- larvitbase-api (npm): affected all versions; fixed in 0.5.5\n- larvitbase-api (npm): affected all versions; fixed in 0.5.5\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2019-5479/ (Markdown: https://insights.sbomify.com/CVE-2019-5479/index.md)","id":"CVE-2019-5479","markdown":"https://insights.sbomify.com/CVE-2019-5479/index.md","name":"CVE-2019-5479","record":{"aliases":["GHSA-xf27-jqwv-gf3r"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Node.js API library","requires_auth":"none","summary":"An attacker can load arbitrary JavaScript files via unintended require, leading to code execution in applications using larvitbase-api.","user_interaction":"not_required","vuln_class":"code_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"hackerone","cpe":[{"product":"larvitbase","vendor":"larvit"}],"cvss":{"score":7.5,"severity":"high","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N","version":"3.1"},"cwes":[{"id":"CWE-829","name":"Inclusion of Functionality from Untrusted Control Sphere"},{"id":"CWE-98","name":"Improper Control of Filename for Include/Require Statement in PHP Program"}],"description":"An unintended require vulnerability in \u003cv0.5.5 larvitbase-api may allow an attacker to load arbitrary non-production code (JavaScript file).","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Unintended Require in larvitbase-api","id":"CVE-2019-5479","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"code_injection","year":"2019"},"n_packages":2,"n_references":1,"next":{"headline":"Path Traversal in statichttpserver","id":"CVE-2019-5480"},"packages":[{"ecosystem":"npm","fixed":["0.5.5"],"introduced":["0"],"last_affected":[],"package":"larvitbase-api","purl":null,"source":"GHSA-xf27-jqwv-gf3r"},{"ecosystem":"npm","fixed":["0.5.5"],"introduced":["0"],"last_affected":[],"package":"larvitbase-api","purl":"pkg:npm/larvitbase-api","source":"GHSA-xf27-jqwv-gf3r"}],"prev":{"headline":"Security feature bypass in Zynq UltraScale+ SoC","id":"CVE-2019-5478"},"products":["larvitbase-api"],"published":"2019-09-03","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-04","vendors":["n/a"]},"summary":"An attacker can load arbitrary JavaScript files via unintended require, leading to code execution in applications using larvitbase-api.","url":"https://insights.sbomify.com/CVE-2019-5479/"}