# CVE-2019-5479: Unintended Require in larvitbase-api

> An attacker can load arbitrary JavaScript files via unintended require, leading to code execution in applications using larvitbase-api.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 3 Sep 2019
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-xf27-jqwv-gf3r

## What is CVE-2019-5479?

CVE-2019-5479 is a high-severity code injection vulnerability in larvitbase-api, published on 3 Sep 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

An unintended require vulnerability in <v0.5.5 larvitbase-api may allow an attacker to load arbitrary non-production code (JavaScript file).

Weakness: CWE-829 (Inclusion of Functionality from Untrusted Control Sphere), CWE-98 (Improper Control of Filename for Include/Require Statement in PHP Program)

## Which versions are affected by CVE-2019-5479?

2 open source packages ship an affected version, including larvitbase-api. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `larvitbase-api` | npm | All versions | 0.5.5 |
| `larvitbase-api` | npm | All versions | 0.5.5 |

Products: Larvit Larvitbase.

## How do I fix CVE-2019-5479?

Upgrade larvitbase-api to 0.5.5 or later.

## Is CVE-2019-5479 being exploited?

There is no known exploitation of CVE-2019-5479 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-5479 and fix it if it is affected.

What it is: CVE-2019-5479 is a high-severity code injection vulnerability in larvitbase-api, published on 3 Sep 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2019-5479 in the wild and no public exploit code.

Affected packages and fixed versions:
- larvitbase-api (npm): affected all versions; fixed in 0.5.5
- larvitbase-api (npm): affected all versions; fixed in 0.5.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-5479/ (Markdown: https://insights.sbomify.com/CVE-2019-5479/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-5479
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-5479
- OSV: https://osv.dev/vulnerability/CVE-2019-5479

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-5479/
Summaries are generated and may contain mistakes; the official description above is the record.
