# CVE-2019-5484: Symlink Arbitrary File Overwrite in bower

> Attackers can write arbitrary files to the system by installing a malicious package, potentially leading to code execution or system compromise.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 13 Sep 2019
- **Updated:** 4 Aug 2024
- **Also known as:** CLSA-2026-1782176268, CLSA-2026-1792163513, GHSA-p6mr-pxg4-68hx

## What is CVE-2019-5484?

CVE-2019-5484 is a high-severity path traversal vulnerability in bower, published on 13 Sep 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Bower before 1.8.8 has a path traversal vulnerability permitting file write in arbitrary locations via install command, which allows attackers to write arbitrary files when a malicious package is extracted.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2019-5484?

2 open source packages ship an affected version, including bower. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `bower` | npm | All versions | 1.8.8 |
| `bower` | npm | All versions | 1.8.8 |

Products: Bower Bower.

## How do I fix CVE-2019-5484?

Upgrade bower to 1.8.8 or later.

## Is CVE-2019-5484 being exploited?

There is no known exploitation of CVE-2019-5484 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-5484 and fix it if it is affected.

What it is: CVE-2019-5484 is a high-severity path traversal vulnerability in bower, published on 13 Sep 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2019-5484 in the wild and no public exploit code.

Affected packages and fixed versions:
- bower (npm): affected all versions; fixed in 1.8.8
- bower (npm): affected all versions; fixed in 1.8.8

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-5484/ (Markdown: https://insights.sbomify.com/CVE-2019-5484/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-5484
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-5484
- OSV: https://osv.dev/vulnerability/CVE-2019-5484

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-5484/
Summaries are generated and may contain mistakes; the official description above is the record.
