# CVE-2019-5647: Rapid7 AppSpider Chrome Plugin Insufficient Session Expiration

> The AppSpider Chrome plugin fails to expire sessions after browser restarts, potentially allowing attackers to hijack active user sessions.

- **Severity:** Medium 4.4 (`CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 22 Jan 2020
- **Updated:** 17 Sep 2024
- **Also known as:** GHSA-4qpq-v2q4-wj9r

## What is CVE-2019-5647?

CVE-2019-5647 is a medium-severity vulnerability in Rapid7 AppSpider, published on 22 Jan 2020. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

The Chrome Plugin for Rapid7 AppSpider can incorrectly keep browser sessions active after recording a macro, even after a restart of the Chrome browser. This behavior could make future session hijacking attempts easier, since the user could believe a session was closed when it was not. This issue affects Rapid7 AppSpider version 3.8.213 and prior versions, and is fixed in version 3.8.215.

Weakness: CWE-613 (DEPRECATED: Insufficient Session Expiration)

## Which versions are affected by CVE-2019-5647?

It affects 1 product.


Products: Rapid7 Appspider.

## How do I fix CVE-2019-5647?

No fix has been published for CVE-2019-5647 yet. Limit exposure of the affected software until one is available.

## Is CVE-2019-5647 being exploited?

There is no known exploitation of CVE-2019-5647 in the wild and no public exploit code.

## Other vulnerabilities in Rapid7 AppSpider

- [CVE-2020-7358](https://insights.sbomify.com/CVE-2020-7358/): Code Injection in Rapid7 AppSpider Pro Installer (medium 5.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-5647 and fix it if it is affected.

What it is: CVE-2019-5647 is a medium-severity vulnerability in Rapid7 AppSpider, published on 22 Jan 2020. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2019-5647 in the wild and no public exploit code.

Affected product: Rapid7 AppSpider. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-5647/ (Markdown: https://insights.sbomify.com/CVE-2019-5647/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-5647
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-5647
- OSV: https://osv.dev/vulnerability/CVE-2019-5647

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-5647/
Summaries are generated and may contain mistakes; the official description above is the record.
