# CVE-2019-5648: LDAP Credential Exposure in Barracuda Load Balancer ADC

> Authenticated administrators can expose LDAP credentials by modifying the LDAP server configuration without re-authentication, risking credential theft.

- **Severity:** High 8.7 (`CVSS:3.0/AV:N/AC:L/PR:H/UI:N/S:C/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 12 Mar 2020
- **Updated:** 17 Sep 2024
- **Also known as:** GHSA-5ghg-57ch-849f

## What is CVE-2019-5648?

CVE-2019-5648 is a high-severity vulnerability in Barracuda Load Balancer ADC, published on 12 Mar 2020. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

Authenticated, administrative access to a Barracuda Load Balancer ADC running unpatched firmware <= v6.4 allows one to edit the LDAP service configuration of the balancer and change the LDAP server to an attacker-controlled system, without having to re-enter LDAP credentials. These steps can be used by any authenticated administrative user to expose the LDAP credentials configured in the LDAP connector over the network.

Weakness: CWE-522 (Insufficiently Protected Credentials)

## Which versions are affected by CVE-2019-5648?

It affects 1 product.


Products: Barracuda Load Balancer Adc Firmware.

## How do I fix CVE-2019-5648?

No fix has been published for CVE-2019-5648 yet. Limit exposure of the affected software until one is available.

## Is CVE-2019-5648 being exploited?

There is no known exploitation of CVE-2019-5648 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-5648 and fix it if it is affected.

What it is: CVE-2019-5648 is a high-severity vulnerability in Barracuda Load Balancer ADC, published on 12 Mar 2020. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2019-5648 in the wild and no public exploit code.

Affected product: Barracuda Load Balancer ADC. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-5648/ (Markdown: https://insights.sbomify.com/CVE-2019-5648/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-5648
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-5648
- OSV: https://osv.dev/vulnerability/CVE-2019-5648

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-5648/
Summaries are generated and may contain mistakes; the official description above is the record.
