# CVE-2019-5715: Silverstripe Framework SQLi Vulnerability

> Attackers can execute arbitrary SQL commands via reflected injection in SilverStripe forms and data objects, potentially accessing or modifying database content.

- **Severity:** Critical 9.8 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 11 Apr 2019
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-wvfw-w3x6-g526

## What is CVE-2019-5715?

CVE-2019-5715 is a critical SQL injection vulnerability in Silverstripe Silverstripe, published on 11 Apr 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

All versions of SilverStripe 3 prior to 3.6.7 and 3.7.3, and all versions of SilverStripe 4 prior to 4.0.7, 4.1.5, 4.2.4, and 4.3.1 allows Reflected SQL Injection through Form and DataObject.

Weakness: CWE-89 (Improper Neutralization of Special Elements used in an SQL Command)

## Which versions are affected by CVE-2019-5715?

12 open source packages ship an affected version, including silverstripe/framework. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `silverstripe/framework` | Packagist | From 3.0.0 | 3.6.7 |
| `silverstripe/framework` | Packagist | From 3.0.0 | 3.6.7 |
| `silverstripe/framework` | Packagist | From 3.7.0 | 3.7.3 |
| `silverstripe/framework` | Packagist | From 3.7.0 | 3.7.3 |
| `silverstripe/framework` | Packagist | From 4.0.0 | 4.0.7 |
| `silverstripe/framework` | Packagist | From 4.0.0 | 4.0.7 |
| `silverstripe/framework` | Packagist | From 4.1.0 | 4.1.5 |
| `silverstripe/framework` | Packagist | From 4.1.0 | 4.1.5 |
| `silverstripe/framework` | Packagist | From 4.2.0 | 4.2.4 |
| `silverstripe/framework` | Packagist | From 4.2.0 | 4.2.4 |
| `silverstripe/framework` | Packagist | From 4.3.0 | 4.3.1 |
| `silverstripe/framework` | Packagist | From 4.3.0 | 4.3.1 |

Products: Silverstripe Silverstripe.

## How do I fix CVE-2019-5715?

Upgrade silverstripe/framework to a fixed version for your release line: 3.6.7, 3.7.3, 4.0.7 or 4.1.5.

## Is CVE-2019-5715 being exploited?

There is no known exploitation of CVE-2019-5715 in the wild and no public exploit code.

## Other vulnerabilities in Silverstripe Silverstripe

- [CVE-2007-2321](https://insights.sbomify.com/CVE-2007-2321/): Other in n/a (critical 10.0)
- [CVE-2019-12204](https://insights.sbomify.com/CVE-2019-12204/): Missing warning can lead to unauthenticated admin access in SilverStripe (critical 9.8)
- [CVE-2019-12437](https://insights.sbomify.com/CVE-2019-12437/): Silverstripe CSRF Protection Bypass via GraphQL (high 8.8)
- [CVE-2020-6164](https://insights.sbomify.com/CVE-2020-6164/): Silverstripe CMS information disclosure (high 7.5)
- [CVE-2020-9280](https://insights.sbomify.com/CVE-2020-9280/): SilverStripe Folders migrated from 3.x may be unsafe to upload to (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-5715 and fix it if it is affected.

What it is: CVE-2019-5715 is a critical SQL injection vulnerability in Silverstripe Silverstripe, published on 11 Apr 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2019-5715 in the wild and no public exploit code.

Affected packages and fixed versions:
- silverstripe/framework (Packagist): affected from 3.0.0; fixed in 3.6.7
- silverstripe/framework (Packagist): affected from 3.0.0; fixed in 3.6.7
- silverstripe/framework (Packagist): affected from 3.7.0; fixed in 3.7.3
- silverstripe/framework (Packagist): affected from 3.7.0; fixed in 3.7.3
- silverstripe/framework (Packagist): affected from 4.0.0; fixed in 4.0.7
- silverstripe/framework (Packagist): affected from 4.0.0; fixed in 4.0.7
- silverstripe/framework (Packagist): affected from 4.1.0; fixed in 4.1.5
- silverstripe/framework (Packagist): affected from 4.1.0; fixed in 4.1.5
- silverstripe/framework (Packagist): affected from 4.2.0; fixed in 4.2.4
- silverstripe/framework (Packagist): affected from 4.2.0; fixed in 4.2.4
- silverstripe/framework (Packagist): affected from 4.3.0; fixed in 4.3.1
- silverstripe/framework (Packagist): affected from 4.3.0; fixed in 4.3.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-5715/ (Markdown: https://insights.sbomify.com/CVE-2019-5715/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-5715
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-5715
- OSV: https://osv.dev/vulnerability/CVE-2019-5715

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-5715/
Summaries are generated and may contain mistakes; the official description above is the record.
