# CVE-2019-5729: splunk-sdk does not properly verify untrusted TLS server certificates

> The Splunk Python SDK fails to verify TLS certificates, allowing attackers to intercept traffic via man-in-the-middle attacks.

- **Severity:** High 8.1 (`CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 19 Mar 2019
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-f58w-649r-qjr9, PYSEC-2019-203

## What is CVE-2019-5729?

CVE-2019-5729 is a high-severity vulnerability in n/a, published on 19 Mar 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Splunk-SDK-Python before 1.6.6 does not properly verify untrusted TLS server certificates, which could result in man-in-the-middle attacks.

Weakness: CWE-295 (Improper Certificate Validation)

## Which versions are affected by CVE-2019-5729?

3 open source packages ship an affected version, including splunk-sdk. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `splunk-sdk` | PyPI | All versions | 1.6.6 |
| `splunk-sdk` | PyPI | All versions | 1.6.6 |
| `splunk-sdk` | PyPI | All versions | 1.6.6 |

Products: Splunk Software Development Kit.

## How do I fix CVE-2019-5729?

Upgrade splunk-sdk to 1.6.6 or later.

## Is CVE-2019-5729 being exploited?

There is no known exploitation of CVE-2019-5729 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-5729 and fix it if it is affected.

What it is: CVE-2019-5729 is a high-severity vulnerability in n/a, published on 19 Mar 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2019-5729 in the wild and no public exploit code.

Affected packages and fixed versions:
- splunk-sdk (PyPI): affected all versions; fixed in 1.6.6
- splunk-sdk (PyPI): affected all versions; fixed in 1.6.6
- splunk-sdk (PyPI): affected all versions; fixed in 1.6.6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-5729/ (Markdown: https://insights.sbomify.com/CVE-2019-5729/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-5729
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-5729
- OSV: https://osv.dev/vulnerability/CVE-2019-5729

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-5729/
Summaries are generated and may contain mistakes; the official description above is the record.
