# CVE-2019-5786: Google Chrome Blink Use-After-Free

> A remote attacker can execute arbitrary code via a crafted HTML page due to an object lifetime issue in the Blink rendering engine.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Yes, since 23 May 2022 (CISA KEV)
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 27 Jun 2019
- **Updated:** 21 Oct 2025
- **Also known as:** DEBIAN-CVE-2019-5786, DSA-4404-1, GHSA-c2gp-86p4-5935, RHSA-2019:0481, UBUNTU-CVE-2019-5786, openSUSE-SU-2019:0298-1

## What is CVE-2019-5786?

CVE-2019-5786 is a medium-severity use after free vulnerability in Google Chrome, published on 27 Jun 2019. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Object lifetime issue in Blink in Google Chrome prior to 72.0.3626.121 allowed a remote attacker to potentially perform out of bounds memory access via a crafted HTML page.

Weakness: CWE-416 (Use After Free)

## Which versions are affected by CVE-2019-5786?

2 open source packages ship an affected version, including puppeteer. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `puppeteer` | npm | All versions | 1.13.0 |
| `puppeteer` | npm | All versions | 1.13.0 |
| `chromium-browser` | Red Hat:rhel_extras:6 | All versions | 0:72.0.3626.121-1.el6_10 |
| `chromium-browser-debuginfo` | Red Hat:rhel_extras:6 | All versions | 0:72.0.3626.121-1.el6_10 |
| `chromium` | SUSE:Package Hub 12 SP2 | All versions | 72.0.3626.121-bp150.2.37.1 |
| `chromium` | SUSE:Package Hub 15 | All versions | 72.0.3626.121-bp150.2.37.1 |
| `chromium` | openSUSE:Leap 15.0 | All versions | 72.0.3626.121-bp150.2.37.1 |

Products: Google Chrome.

## How do I fix CVE-2019-5786?

Upgrade puppeteer to 1.13.0 or later. US federal agencies must fix it by 13 Jun 2022.

## Is CVE-2019-5786 being exploited?

Yes. Attackers have exploited CVE-2019-5786 in the wild since at least 23 May 2022.

Public exploit code:

- FileReader Exploit (github_poc): https://github.com/exodusintel/CVE-2019-5786
- Chrome 72.0.3626.119 FileReader UaF exploit for Windows 7 x86 (metasploit)
- Google Chrome 72.0.3626.119 - 'FileReader' Use-After-Free (Metasploit) (exploitdb)
- Google Chrome 72.0.3626.119 - 'FileReader' Use-After-Free (Metasploit) (exploitdb)

## Other vulnerabilities in Google Chrome

- [CVE-2022-4135](https://insights.sbomify.com/CVE-2022-4135/): Google Chromium GPU Heap Buffer Overflow (critical 9.6, exploited in the wild)
- [CVE-2020-16017](https://insights.sbomify.com/CVE-2020-16017/): Google Chrome Use-After-Free (critical 9.6, exploited in the wild)
- [CVE-2020-16010](https://insights.sbomify.com/CVE-2020-16010/): Google Chrome for Android UI Heap Buffer Overflow (critical 9.6, exploited in the wild)
- [CVE-2026-87491](https://insights.sbomify.com/CVE-2026-87491/): Google Chromium V8 Out of Bounds Write (high 8.8, exploited in the wild)
- [CVE-2026-85046](https://insights.sbomify.com/CVE-2026-85046/): Google Chromium V8 Type Confusion (high 8.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-5786 and fix it if it is affected.

What it is: CVE-2019-5786 is a medium-severity use after free vulnerability in Google Chrome, published on 27 Jun 2019. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: Yes. Attackers have exploited CVE-2019-5786 in the wild since at least 23 May 2022.

Affected packages and fixed versions:
- puppeteer (npm): affected all versions; fixed in 1.13.0
- puppeteer (npm): affected all versions; fixed in 1.13.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-5786/ (Markdown: https://insights.sbomify.com/CVE-2019-5786/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-5786
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-5786
- OSV: https://osv.dev/vulnerability/CVE-2019-5786

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-5786/
Summaries are generated and may contain mistakes; the official description above is the record.
