{"answers":{"affected":"2 open source packages ship an affected version, including nokogiri. It affects 2 products.","exploited":"There is no known exploitation of CVE-2019-5815 in the wild and no public exploit code.","fix":"Upgrade nokogiri to 1.10.5 or later.","what":"CVE-2019-5815 is a high-severity memory corruption vulnerability in Debian Debian Linux, published on 11 Dec 2019. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2019-5815 and fix it if it is affected.\n\nWhat it is: CVE-2019-5815 is a high-severity memory corruption vulnerability in Debian Debian Linux, published on 11 Dec 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2019-5815 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- nokogiri (RubyGems): affected all versions; fixed in 1.10.5\n- nokogiri (RubyGems): affected all versions; fixed in 1.10.5\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2019-5815/ (Markdown: https://insights.sbomify.com/CVE-2019-5815/index.md)","id":"CVE-2019-5815","markdown":"https://insights.sbomify.com/CVE-2019-5815/index.md","name":"CVE-2019-5815","record":{"aliases":["DEBIAN-CVE-2019-5815","GHSA-vmfx-gcfq-wvm2","UBUNTU-CVE-2019-5815"],"analysis":{"component_type":"browser","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Chrome browser","requires_auth":"none","summary":"Type confusion in libxslt allows attackers to exploit heap corruption via crafted XML, potentially leading to code execution in Chrome.","user_interaction":"not_required","vuln_class":"memory_corruption"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"Chrome","cpe":[{"product":"debian_linux","vendor":"debian"},{"product":"libxslt","vendor":"xmlsoft"}],"cvss":{"score":7.5,"severity":"high","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H","version":"3.1"},"cwes":[{"id":"CWE-843","name":"Access of Resource Using Incompatible Type"},{"id":"CWE-787","name":"Out-of-bounds Write"}],"description":"Type confusion in xsltNumberFormatGetMultipleLevel prior to libxslt 1.1.33 could allow attackers to potentially exploit heap corruption via crafted XML data.","ecosystems":["RubyGems"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Nokogiri implementation of libxslt vulnerable to heap corruption","id":"CVE-2019-5815","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"RubyGems","product":"debian:debian_linux","products":["debian:debian_linux"],"type":"memory_corruption","year":"2019"},"n_packages":2,"n_references":3,"next":{"headline":"Other in Chrome","id":"CVE-2019-5816"},"packages":[{"ecosystem":"RubyGems","fixed":["1.10.5"],"introduced":["0"],"last_affected":[],"package":"nokogiri","purl":null,"source":"GHSA-vmfx-gcfq-wvm2"},{"ecosystem":"RubyGems","fixed":["1.10.5"],"introduced":["0"],"last_affected":[],"package":"nokogiri","purl":"pkg:gem/nokogiri","source":"GHSA-vmfx-gcfq-wvm2"}],"prev":{"headline":"Information disclosure in Chrome","id":"CVE-2019-5814"},"products":["Chrome"],"published":"2019-12-11","related":[{"cvss_score":10,"headline":"ProFTPD Improper Access Control","id":"CVE-2015-3306","kev_date_added":"2026-10-08","published":"2015-05-18"},{"cvss_score":9.9,"headline":"RoundCube Webmail Deserialization of Untrusted Data","id":"CVE-2025-49113","kev_date_added":"2026-02-20","published":"2025-06-02"},{"cvss_score":9.8,"headline":"GNU InetUtils Argument Injection","id":"CVE-2026-24061","kev_date_added":"2026-01-26","published":"2026-01-21"},{"cvss_score":9.8,"headline":"Linux Kernel Improper Check for Unusual or Exceptional Conditions","id":"CVE-2025-39682","kev_date_added":"2026-09-18","published":"2025-09-05"},{"cvss_score":9.8,"headline":"Mozilla Firefox Use-After-Free","id":"CVE-2024-9680","kev_date_added":"2024-10-15","published":"2024-10-09"},{"cvss_score":9.8,"headline":"RARLAB UnRAR Directory Traversal","id":"CVE-2022-30333","kev_date_added":"2022-08-09","published":"2022-05-09"},{"cvss_score":9.8,"headline":"Roundcube Webmail SQL Injection","id":"CVE-2021-44026","kev_date_added":"2023-06-22","published":"2021-11-19"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-04","vendors":["Google"]},"summary":"Type confusion in libxslt allows attackers to exploit heap corruption via crafted XML, potentially leading to code execution in Chrome.","url":"https://insights.sbomify.com/CVE-2019-5815/"}