{"answers":{"affected":"It affects 2 products.","exploited":"There is no known exploitation of CVE-2019-5882 in the wild and no public exploit code.","fix":"Upgrade to a fixed version.","what":"CVE-2019-5882 is a critical use after free vulnerability in Canonical Ubuntu Linux, published on 9 Jan 2019. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2019-5882 and fix it if it is affected.\n\nWhat it is: CVE-2019-5882 is a critical use after free vulnerability in Canonical Ubuntu Linux, published on 9 Jan 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2019-5882 in the wild and no public exploit code.\n\nAffected product: Canonical Ubuntu Linux. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2019-5882/ (Markdown: https://insights.sbomify.com/CVE-2019-5882/index.md)","id":"CVE-2019-5882","markdown":"https://insights.sbomify.com/CVE-2019-5882/index.md","name":"CVE-2019-5882","record":{"aliases":["ALPINE-CVE-2019-5882","DEBIAN-CVE-2019-5882","GHSA-843w-9chm-9mvw","MGASA-2019-0091","UBUNTU-CVE-2019-5882","USN-3862-1","openSUSE-SU-2019:0048-1"],"analysis":{"component_type":"desktop_application","fix_type":"upgrade","impacts":["code_execution","denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Irssi IRC client","requires_auth":"none","summary":"A use-after-free vulnerability in Irssi allows attackers to execute arbitrary code or cause a denial of service via hidden lines in the scroll buffer.","user_interaction":"not_required","vuln_class":"use_after_free"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"ubuntu_linux","vendor":"canonical"},{"product":"irssi","vendor":"irssi"}],"cvss":{"score":9.8,"severity":"critical","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","version":"3.0"},"cwes":[{"id":"CWE-416","name":"Use After Free"}],"description":"Irssi 1.1.x before 1.1.2 has a use after free when hidden lines are expired from the scroll buffer.","ecosystems":["SUSE:Package Hub 12","SUSE:Package Hub 15","openSUSE:Leap 15.0"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Use after free in n/a","id":"CVE-2019-5882","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":"canonical:ubuntu_linux","products":["canonical:ubuntu_linux"],"type":"use_after_free","year":"2019"},"n_packages":3,"n_references":4,"next":{"headline":"Missing authorization in n/a","id":"CVE-2019-5883"},"packages":[{"ecosystem":"SUSE:Package Hub 12","fixed":["1.1.2-bp150.3.4.1"],"introduced":["0"],"last_affected":[],"package":"irssi","purl":"pkg:rpm/suse/irssi\u0026distro=SUSE%20Package%20Hub%2012","source":"openSUSE-SU-2019:0048-1"},{"ecosystem":"SUSE:Package Hub 15","fixed":["1.1.2-bp150.3.4.1"],"introduced":["0"],"last_affected":[],"package":"irssi","purl":"pkg:rpm/suse/irssi\u0026distro=SUSE%20Package%20Hub%2015","source":"openSUSE-SU-2019:0048-1"},{"ecosystem":"openSUSE:Leap 15.0","fixed":["1.1.2-bp150.3.4.1"],"introduced":["0"],"last_affected":[],"package":"irssi","purl":"pkg:rpm/opensuse/irssi\u0026distro=openSUSE%20Leap%2015.0","source":"openSUSE-SU-2019:0048-1"}],"prev":{"headline":"Information disclosure in Chrome","id":"CVE-2019-5881"},"products":["n/a"],"published":"2019-01-09","related":[{"cvss_score":9.8,"headline":"SaltStack Salt Authentication Bypass","id":"CVE-2020-11651","kev_date_added":"2021-11-03","published":"2020-04-30"},{"cvss_score":9.8,"headline":"OpenSMTPD Remote Code Execution","id":"CVE-2020-7247","kev_date_added":"2022-03-25","published":"2020-01-29"},{"cvss_score":9.8,"headline":"Exim Out-of-bounds Write","id":"CVE-2019-16928","kev_date_added":"2022-03-03","published":"2019-09-27"},{"cvss_score":9.8,"headline":"Exim Buffer Overflow","id":"CVE-2018-6789","kev_date_added":"2021-11-03","published":"2018-02-08"},{"cvss_score":9.8,"headline":"Oracle Java SE and Java SE Embedded Remote Code Execution","id":"CVE-2015-2590","kev_date_added":"2022-03-03","published":"2015-07-16"},{"cvss_score":9.8,"headline":"Oracle JRE Remote Code Execution","id":"CVE-2013-0422","kev_date_added":"2022-05-25","published":"2013-01-10"},{"cvss_score":9.8,"headline":"Oracle Java SE Runtime Environment (JRE) Arbitrary Code Execution","id":"CVE-2011-3544","kev_date_added":"2022-03-03","published":"2011-10-19"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"openSUSE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-04","vendors":["n/a"]},"summary":"A use-after-free vulnerability in Irssi allows attackers to execute arbitrary code or cause a denial of service via hidden lines in the scroll buffer.","url":"https://insights.sbomify.com/CVE-2019-5882/"}