# CVE-2019-5884: Sensitive Data Exposure in elFinder

> elFinder leaks information when the PHP curl extension is enabled and safe_mode or open_basedir are not configured.

- **Severity:** Medium 5.9 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 10 Jan 2019
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-jcgc-vxqg-85xx

## What is CVE-2019-5884?

CVE-2019-5884 is a medium-severity vulnerability in n/a, published on 10 Jan 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

php/elFinder.class.php in elFinder before 2.1.45 leaks information if PHP's curl extension is enabled and safe_mode or open_basedir is not set.

Weakness: CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2019-5884?

2 open source packages ship an affected version, including studio-42/elfinder. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `studio-42/elfinder` | Packagist | All versions | 2.1.45 |
| `studio-42/elfinder` | Packagist | All versions | 2.1.45 |

Products: Std42 Elfinder.

## How do I fix CVE-2019-5884?

Upgrade studio-42/elfinder to 2.1.45 or later.

## Is CVE-2019-5884 being exploited?

There is no known exploitation of CVE-2019-5884 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2023-52044](https://insights.sbomify.com/CVE-2023-52044/): File upload in n/a (critical 9.8)
- [CVE-2024-38909](https://insights.sbomify.com/CVE-2024-38909/): Studio 42 elFinder vulnerable to Incorrect Access Control (critical 9.8)
- [CVE-2022-27115](https://insights.sbomify.com/CVE-2022-27115/): RCE in Studio-42 elFinder on Windows before 2.1.61 (critical 9.8)
- [CVE-2021-43421](https://insights.sbomify.com/CVE-2021-43421/): elFinder Unrestricted File Upload vulnerability (critical 9.8)
- [CVE-2021-32682](https://insights.sbomify.com/CVE-2021-32682/): Multiple vulnerabilities leading to RCE (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-5884 and fix it if it is affected.

What it is: CVE-2019-5884 is a medium-severity vulnerability in n/a, published on 10 Jan 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2019-5884 in the wild and no public exploit code.

Affected packages and fixed versions:
- studio-42/elfinder (Packagist): affected all versions; fixed in 2.1.45
- studio-42/elfinder (Packagist): affected all versions; fixed in 2.1.45

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-5884/ (Markdown: https://insights.sbomify.com/CVE-2019-5884/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-5884
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-5884
- OSV: https://osv.dev/vulnerability/CVE-2019-5884

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-5884/
Summaries are generated and may contain mistakes; the official description above is the record.
