{"answers":{"affected":"3 open source packages ship an affected version, including matrix-synapse. It affects 2 products.","exploited":"There is no known exploitation of CVE-2019-5885 in the wild and no public exploit code.","fix":"Upgrade matrix-synapse to 0.34.0.1 or later.","what":"CVE-2019-5885 is a high-severity vulnerability in Fedoraproject Fedora, published on 19 Mar 2019. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2019-5885 and fix it if it is affected.\n\nWhat it is: CVE-2019-5885 is a high-severity vulnerability in Fedoraproject Fedora, published on 19 Mar 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2019-5885 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- matrix-synapse (PyPI): affected all versions; fixed in 0.34.0.1\n- matrix-synapse (PyPI): affected all versions; fixed in 0.34.0.1\n- matrix-synapse (PyPI): affected all versions; fixed in 0.34.0.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2019-5885/ (Markdown: https://insights.sbomify.com/CVE-2019-5885/index.md)","id":"CVE-2019-5885","markdown":"https://insights.sbomify.com/CVE-2019-5885/index.md","name":"CVE-2019-5885","record":{"aliases":["GHSA-jrqm-v8cv-53ww","PYSEC-2019-187","UBUNTU-CVE-2019-5885"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["account_takeover"],"network_reachable":"yes","non_default_config":true,"product_category":"Matrix Synapse server","requires_auth":"none","summary":"Remote attackers can impersonate users if the macaroon_secret_key is not explicitly configured, due to predictable secret derivation.","user_interaction":"not_required","vuln_class":"weak_cryptography"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"fedora","vendor":"fedoraproject"},{"product":"synapse","vendor":"matrix"}],"cvss":{"score":7.5,"severity":"high","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N","version":"3.0"},"cwes":[{"id":"CWE-330","name":"Use of Insufficiently Random Values"}],"description":"Matrix Synapse before 0.34.0.1, when the macaroon_secret_key authentication parameter is not set, uses a predictable value to derive a secret key and other secrets which could allow remote attackers to impersonate users.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Matrix Synapse Predictable Secret Key","id":"CVE-2019-5885","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":"fedoraproject:fedora","products":["fedoraproject:fedora"],"type":"weak_cryptography","year":"2019"},"n_packages":3,"n_references":4,"next":{"headline":"Missing authorization in n/a","id":"CVE-2019-5886"},"packages":[{"ecosystem":"PyPI","fixed":["0.34.0.1"],"introduced":["0"],"last_affected":[],"package":"matrix-synapse","purl":null,"source":"GHSA-jrqm-v8cv-53ww"},{"ecosystem":"PyPI","fixed":["0.34.0.1"],"introduced":["0"],"last_affected":[],"package":"matrix-synapse","purl":"pkg:pypi/matrix-synapse","source":"GHSA-jrqm-v8cv-53ww"},{"ecosystem":"PyPI","fixed":["0.34.0.1"],"introduced":["0"],"last_affected":[],"package":"matrix-synapse","purl":"pkg:pypi/matrix-synapse","source":"PYSEC-2019-187"}],"prev":{"headline":"Sensitive Data Exposure in elFinder","id":"CVE-2019-5884"},"products":["n/a"],"published":"2019-03-19","related":[{"cvss_score":9.8,"headline":"PHP-CGI OS Command Injection","id":"CVE-2024-4577","kev_date_added":"2024-06-12","published":"2024-06-09"},{"cvss_score":9.8,"headline":"Grafana Authentication Bypass","id":"CVE-2021-39226","kev_date_added":"2022-08-25","published":"2021-10-05"},{"cvss_score":9.8,"headline":"VMware ESXi and Horizon DaaS OpenSLP Heap-Based Buffer Overflow","id":"CVE-2019-5544","kev_date_added":"2021-11-03","published":"2019-12-06"},{"cvss_score":9.6,"headline":"Google Chromium V8 Type Confusion","id":"CVE-2024-4947","kev_date_added":"2024-05-20","published":"2024-05-15"},{"cvss_score":9.6,"headline":"Google Chromium Visuals Use-After-Free","id":"CVE-2024-4671","kev_date_added":"2024-05-13","published":"2024-05-09"},{"cvss_score":9.6,"headline":"Google Chromium Mojo Insufficient Data Validation","id":"CVE-2022-3075","kev_date_added":"2022-09-08","published":"2022-09-26"},{"cvss_score":9.6,"headline":"Google Chromium Indexed DB API Use-After-Free","id":"CVE-2021-30633","kev_date_added":"2021-11-03","published":"2021-10-08"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-04","vendors":["n/a"]},"summary":"Remote attackers can impersonate users if the macaroon_secret_key is not explicitly configured, due to predictable secret derivation.","url":"https://insights.sbomify.com/CVE-2019-5885/"}