# CVE-2019-5885: Matrix Synapse Predictable Secret Key

> Remote attackers can impersonate users if the macaroon_secret_key is not explicitly configured, due to predictable secret derivation.

- **Severity:** High 7.5 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 19 Mar 2019
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-jrqm-v8cv-53ww, PYSEC-2019-187, UBUNTU-CVE-2019-5885

## What is CVE-2019-5885?

CVE-2019-5885 is a high-severity vulnerability in Fedoraproject Fedora, published on 19 Mar 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Matrix Synapse before 0.34.0.1, when the macaroon_secret_key authentication parameter is not set, uses a predictable value to derive a secret key and other secrets which could allow remote attackers to impersonate users.

Weakness: CWE-330 (Use of Insufficiently Random Values)

## Which versions are affected by CVE-2019-5885?

3 open source packages ship an affected version, including matrix-synapse. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `matrix-synapse` | PyPI | All versions | 0.34.0.1 |
| `matrix-synapse` | PyPI | All versions | 0.34.0.1 |
| `matrix-synapse` | PyPI | All versions | 0.34.0.1 |

Products: Fedoraproject Fedora, Matrix Synapse.

## How do I fix CVE-2019-5885?

Upgrade matrix-synapse to 0.34.0.1 or later.

## Is CVE-2019-5885 being exploited?

There is no known exploitation of CVE-2019-5885 in the wild and no public exploit code.

## Other vulnerabilities in Fedoraproject Fedora

- [CVE-2024-4577](https://insights.sbomify.com/CVE-2024-4577/): PHP-CGI OS Command Injection (critical 9.8, exploited in the wild)
- [CVE-2021-39226](https://insights.sbomify.com/CVE-2021-39226/): Grafana Authentication Bypass (critical 9.8, exploited in the wild)
- [CVE-2019-5544](https://insights.sbomify.com/CVE-2019-5544/): VMware ESXi and Horizon DaaS OpenSLP Heap-Based Buffer Overflow (critical 9.8, exploited in the wild)
- [CVE-2024-4947](https://insights.sbomify.com/CVE-2024-4947/): Google Chromium V8 Type Confusion (critical 9.6, exploited in the wild)
- [CVE-2024-4671](https://insights.sbomify.com/CVE-2024-4671/): Google Chromium Visuals Use-After-Free (critical 9.6, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-5885 and fix it if it is affected.

What it is: CVE-2019-5885 is a high-severity vulnerability in Fedoraproject Fedora, published on 19 Mar 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2019-5885 in the wild and no public exploit code.

Affected packages and fixed versions:
- matrix-synapse (PyPI): affected all versions; fixed in 0.34.0.1
- matrix-synapse (PyPI): affected all versions; fixed in 0.34.0.1
- matrix-synapse (PyPI): affected all versions; fixed in 0.34.0.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-5885/ (Markdown: https://insights.sbomify.com/CVE-2019-5885/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-5885
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-5885
- OSV: https://osv.dev/vulnerability/CVE-2019-5885

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-5885/
Summaries are generated and may contain mistakes; the official description above is the record.
