# CVE-2019-6035: Athenz vulnerable to Open Redirect

> Remote attackers can redirect users to arbitrary websites for phishing via crafted pages in Athenz.

- **Severity:** Medium 6.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 26 Dec 2019
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-9hg5-7hwc-v434

## What is CVE-2019-6035?

CVE-2019-6035 is a medium-severity vulnerability in Verison Media Athenz, published on 26 Dec 2019. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Open redirect vulnerability in Athenz v1.8.24 and earlier allows remote attackers to redirect users to arbitrary web sites and conduct phishing attacks via a specially crafted page.

Weakness: CWE-601 (URL Redirection to Untrusted Site)

## Which versions are affected by CVE-2019-6035?

2 open source packages ship an affected version, including com.yahoo.athenz:athenz. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `com.yahoo.athenz:athenz` | Maven | All versions | 1.8.25 |
| `com.yahoo.athenz:athenz` | Maven | All versions | 1.8.25 |

Products: Yahoo Athenz.

## How do I fix CVE-2019-6035?

Upgrade com.yahoo.athenz:athenz to 1.8.25 or later.

## Is CVE-2019-6035 being exploited?

There is no known exploitation of CVE-2019-6035 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-6035 and fix it if it is affected.

What it is: CVE-2019-6035 is a medium-severity vulnerability in Verison Media Athenz, published on 26 Dec 2019. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2019-6035 in the wild and no public exploit code.

Affected packages and fixed versions:
- com.yahoo.athenz:athenz (Maven): affected all versions; fixed in 1.8.25
- com.yahoo.athenz:athenz (Maven): affected all versions; fixed in 1.8.25

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-6035/ (Markdown: https://insights.sbomify.com/CVE-2019-6035/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-6035
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-6035
- OSV: https://osv.dev/vulnerability/CVE-2019-6035

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-6035/
Summaries are generated and may contain mistakes; the official description above is the record.
