# CVE-2019-6139: File upload in Forcepoint User ID (FUID) server

> Remote attackers can upload arbitrary files to the Forcepoint User ID server, potentially leading to remote code execution.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 7 Feb 2019
- **Updated:** 17 Sep 2024
- **Also known as:** GHSA-3pcr-r262-49qp

## What is CVE-2019-6139?

CVE-2019-6139 is a critical vulnerability in Forcepoint User ID (FUID) server, published on 7 Feb 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Forcepoint User ID (FUID) server versions up to 1.2 have a remote arbitrary file upload vulnerability on TCP port 5001. Successful exploitation of this vulnerability may lead to remote code execution. To fix this vulnerability, upgrade to FUID version 1.3 or higher. To prevent the vulnerability on FUID versions 1.2 and below, apply local firewall rules on the FUID server to disable all external access to port TCP/5001. FUID requires this port only for local connections through the loopback interface.

Weakness: CWE-434 (Unrestricted Upload of File with Dangerous Type)

## Which versions are affected by CVE-2019-6139?

It affects 1 product.


Products: Forcepoint User Id.

## How do I fix CVE-2019-6139?

No fix has been published for CVE-2019-6139 yet. Limit exposure of the affected software until one is available.

## Is CVE-2019-6139 being exploited?

There is no known exploitation of CVE-2019-6139 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-6139 and fix it if it is affected.

What it is: CVE-2019-6139 is a critical vulnerability in Forcepoint User ID (FUID) server, published on 7 Feb 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2019-6139 in the wild and no public exploit code.

Affected product: Forcepoint User ID (FUID) server. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-6139/ (Markdown: https://insights.sbomify.com/CVE-2019-6139/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-6139
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-6139
- OSV: https://osv.dev/vulnerability/CVE-2019-6139

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-6139/
Summaries are generated and may contain mistakes; the official description above is the record.
