{"answers":{"affected":"7 open source packages ship an affected version, including drupal/drupal and drupal/core. It affects 2 products.","exploited":"There is no known exploitation of CVE-2019-6338 in the wild and no public exploit code.","fix":"Upgrade drupal/drupal to a fixed version for your release line: 7.62.0, 8.5.9 or 8.6.6.","what":"CVE-2019-6338 is a high-severity unsafe deserialization vulnerability in Debian Debian Linux, published on 22 Jan 2019. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2019-6338 and fix it if it is affected.\n\nWhat it is: CVE-2019-6338 is a high-severity unsafe deserialization vulnerability in Debian Debian Linux, published on 22 Jan 2019. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2019-6338 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- drupal/drupal (Packagist): affected from 7.0.0; fixed in 7.62.0\n- drupal/drupal (Packagist): affected from 7.0.0; fixed in 7.62.0\n- drupal/drupal (Packagist): affected from 8.0.0; fixed in 8.5.9\n- drupal/drupal (Packagist): affected from 8.0.0; fixed in 8.5.9\n- drupal/drupal (Packagist): affected from 8.6.0; fixed in 8.6.6\n- drupal/drupal (Packagist): affected from 8.6.0; fixed in 8.6.6\n- drupal/core (Packagist): affected from 8.0.0; fixed in 8.5.9, 8.6.6\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2019-6338/ (Markdown: https://insights.sbomify.com/CVE-2019-6338/index.md)","id":"CVE-2019-6338","markdown":"https://insights.sbomify.com/CVE-2019-6338/index.md","name":"CVE-2019-6338","record":{"aliases":["DLA-1685-1","DRUPAL-CORE-2019-001","GHSA-6rmq-x2hv-vxpp","UBUNTU-CVE-2019-6338"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":true,"product_category":"Drupal core","requires_auth":"low_privilege","summary":"Attackers can execute arbitrary code via unsafe deserialization in the bundled Archive_Tar library, affecting specific Drupal configurations.","user_interaction":"required","vuln_class":"deserialization"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"drupal","cpe":[{"product":"debian_linux","vendor":"debian"},{"product":"drupal","vendor":"drupal"}],"cvss":{"score":8,"severity":"high","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:H","version":"3.0"},"cwes":[{"id":"CWE-502","name":"Deserialization of Untrusted Data"}],"description":"In Drupal Core versions 7.x prior to 7.62, 8.6.x prior to 8.6.6 and 8.5.x prior to 8.5.9; Drupal core uses the third-party PEAR Archive_Tar library. This library has released a security update which impacts some Drupal configurations. Refer to CVE-2018-1000888 for details","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"third-party PEAR Archive_Tar library updates","id":"CVE-2019-6338","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":"debian:debian_linux","products":["debian:debian_linux","drupal:drupal"],"type":"deserialization","year":"2019"},"n_packages":7,"n_references":4,"next":{"headline":"PHAR stream wrapper Arbitrary PHP code execution","id":"CVE-2019-6339"},"packages":[{"ecosystem":"Packagist","fixed":["8.5.9","8.6.6"],"introduced":["8.0.0","8.6.0"],"last_affected":[],"package":"drupal/core","purl":"pkg:composer/drupal/core","source":"DRUPAL-CORE-2019-001"},{"ecosystem":"Packagist","fixed":["7.62.0"],"introduced":["7.0.0"],"last_affected":[],"package":"drupal/drupal","purl":null,"source":"GHSA-6rmq-x2hv-vxpp"},{"ecosystem":"Packagist","fixed":["7.62.0"],"introduced":["7.0.0"],"last_affected":[],"package":"drupal/drupal","purl":"pkg:composer/drupal/drupal","source":"GHSA-6rmq-x2hv-vxpp"},{"ecosystem":"Packagist","fixed":["8.5.9"],"introduced":["8.0.0"],"last_affected":[],"package":"drupal/drupal","purl":null,"source":"GHSA-6rmq-x2hv-vxpp"},{"ecosystem":"Packagist","fixed":["8.5.9"],"introduced":["8.0.0"],"last_affected":[],"package":"drupal/drupal","purl":"pkg:composer/drupal/drupal","source":"GHSA-6rmq-x2hv-vxpp"},{"ecosystem":"Packagist","fixed":["8.6.6"],"introduced":["8.6.0"],"last_affected":[],"package":"drupal/drupal","purl":null,"source":"GHSA-6rmq-x2hv-vxpp"},{"ecosystem":"Packagist","fixed":["8.6.6"],"introduced":["8.6.0"],"last_affected":[],"package":"drupal/drupal","purl":"pkg:composer/drupal/drupal","source":"GHSA-6rmq-x2hv-vxpp"}],"prev":{"headline":"Denial of service in HP OfficeJet Pro 8210 Printer series,HP PageWide 352dw Printer,HP PageWide 377dw Multifunction Printer,HP PageWide Managed P55250dw Printer series,HP PageWide Managed P57750dw Multifunction Printer series,HP PageWide Managed P52750dw Multifunction Printer,HP PageWide Pro 452dn Printer series,HP PageWide Pro 452dw Printer series,HP PageWide Pro 477dn Multifunction Printer series,HP PageWide Pro 477dw Multifunction Printer series,HP PageWide Pro 552dw Printer series,HP PageWide Pro 577dw Multifunction Printer series","id":"CVE-2019-6337"},"products":["Drupal core"],"published":"2019-01-22","related":[{"cvss_score":10,"headline":"ProFTPD Improper Access Control","id":"CVE-2015-3306","kev_date_added":"2026-10-08","published":"2015-05-18"},{"cvss_score":9.9,"headline":"RoundCube Webmail Deserialization of Untrusted Data","id":"CVE-2025-49113","kev_date_added":"2026-02-20","published":"2025-06-02"},{"cvss_score":9.8,"headline":"GNU InetUtils Argument Injection","id":"CVE-2026-24061","kev_date_added":"2026-01-26","published":"2026-01-21"},{"cvss_score":9.8,"headline":"Linux Kernel Improper Check for Unusual or Exceptional Conditions","id":"CVE-2025-39682","kev_date_added":"2026-09-18","published":"2025-09-05"},{"cvss_score":9.8,"headline":"Mozilla Firefox Use-After-Free","id":"CVE-2024-9680","kev_date_added":"2024-10-15","published":"2024-10-09"},{"cvss_score":9.8,"headline":"RARLAB UnRAR Directory Traversal","id":"CVE-2022-30333","kev_date_added":"2022-08-09","published":"2022-05-09"},{"cvss_score":9.8,"headline":"Roundcube Webmail SQL Injection","id":"CVE-2021-44026","kev_date_added":"2023-06-22","published":"2021-11-19"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"MIT","name":"Drupal","prefix":"DRUPAL"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-09-16","vendors":["Drupal"]},"summary":"Attackers can execute arbitrary code via unsafe deserialization in the bundled Archive_Tar library, affecting specific Drupal configurations.","url":"https://insights.sbomify.com/CVE-2019-6338/"}