# CVE-2019-6338: third-party PEAR Archive_Tar library updates

> Attackers can execute arbitrary code via unsafe deserialization in the bundled Archive_Tar library, affecting specific Drupal configurations.

- **Severity:** High 8.0 (`CVSS:3.0/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 22 Jan 2019
- **Updated:** 16 Sep 2024
- **Also known as:** DLA-1685-1, DRUPAL-CORE-2019-001, GHSA-6rmq-x2hv-vxpp, UBUNTU-CVE-2019-6338

## What is CVE-2019-6338?

CVE-2019-6338 is a high-severity unsafe deserialization vulnerability in Debian Debian Linux, published on 22 Jan 2019. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

In Drupal Core versions 7.x prior to 7.62, 8.6.x prior to 8.6.6 and 8.5.x prior to 8.5.9; Drupal core uses the third-party PEAR Archive_Tar library. This library has released a security update which impacts some Drupal configurations. Refer to CVE-2018-1000888 for details

Weakness: CWE-502 (Deserialization of Untrusted Data)

## Which versions are affected by CVE-2019-6338?

7 open source packages ship an affected version, including drupal/drupal and drupal/core. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `drupal/drupal` | Packagist | From 7.0.0 | 7.62.0 |
| `drupal/drupal` | Packagist | From 7.0.0 | 7.62.0 |
| `drupal/drupal` | Packagist | From 8.0.0 | 8.5.9 |
| `drupal/drupal` | Packagist | From 8.0.0 | 8.5.9 |
| `drupal/drupal` | Packagist | From 8.6.0 | 8.6.6 |
| `drupal/drupal` | Packagist | From 8.6.0 | 8.6.6 |
| `drupal/core` | Packagist | From 8.0.0 | 8.5.9, 8.6.6 |

Products: Debian Debian Linux, Drupal Drupal.

## How do I fix CVE-2019-6338?

Upgrade drupal/drupal to a fixed version for your release line: 7.62.0, 8.5.9 or 8.6.6.

## Is CVE-2019-6338 being exploited?

There is no known exploitation of CVE-2019-6338 in the wild and no public exploit code.

## Other vulnerabilities in Debian Debian Linux

- [CVE-2015-3306](https://insights.sbomify.com/CVE-2015-3306/): ProFTPD Improper Access Control (critical 10.0, exploited in the wild)
- [CVE-2025-49113](https://insights.sbomify.com/CVE-2025-49113/): RoundCube Webmail Deserialization of Untrusted Data (critical 9.9, exploited in the wild)
- [CVE-2026-24061](https://insights.sbomify.com/CVE-2026-24061/): GNU InetUtils Argument Injection (critical 9.8, exploited in the wild)
- [CVE-2025-39682](https://insights.sbomify.com/CVE-2025-39682/): Linux Kernel Improper Check for Unusual or Exceptional Conditions (critical 9.8, exploited in the wild)
- [CVE-2024-9680](https://insights.sbomify.com/CVE-2024-9680/): Mozilla Firefox Use-After-Free (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-6338 and fix it if it is affected.

What it is: CVE-2019-6338 is a high-severity unsafe deserialization vulnerability in Debian Debian Linux, published on 22 Jan 2019. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2019-6338 in the wild and no public exploit code.

Affected packages and fixed versions:
- drupal/drupal (Packagist): affected from 7.0.0; fixed in 7.62.0
- drupal/drupal (Packagist): affected from 7.0.0; fixed in 7.62.0
- drupal/drupal (Packagist): affected from 8.0.0; fixed in 8.5.9
- drupal/drupal (Packagist): affected from 8.0.0; fixed in 8.5.9
- drupal/drupal (Packagist): affected from 8.6.0; fixed in 8.6.6
- drupal/drupal (Packagist): affected from 8.6.0; fixed in 8.6.6
- drupal/core (Packagist): affected from 8.0.0; fixed in 8.5.9, 8.6.6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-6338/ (Markdown: https://insights.sbomify.com/CVE-2019-6338/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-6338
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-6338
- OSV: https://osv.dev/vulnerability/CVE-2019-6338

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-6338/
Summaries are generated and may contain mistakes; the official description above is the record.
